summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-08-12 18:20:57 +0000
committerTilman Klar <phoenix@gentoo.org>2002-08-12 18:20:57 +0000
commitac557649eaa678fd0cf4daa651db4c2764421056 (patch)
tree6af828ad694d6b12f8df49e3e2cc438623bbdd9a /sys-apps/apcupsd/apcupsd-3.8.5.ebuild
parentNew ebuild. Changed --prefix/ to --prefix/usr and added --bindir (this fixes ... (diff)
downloadgentoo-2-ac557649eaa678fd0cf4daa651db4c2764421056.tar.gz
gentoo-2-ac557649eaa678fd0cf4daa651db4c2764421056.tar.bz2
gentoo-2-ac557649eaa678fd0cf4daa651db4c2764421056.zip
Bumped to new version.
Diffstat (limited to 'sys-apps/apcupsd/apcupsd-3.8.5.ebuild')
-rw-r--r--sys-apps/apcupsd/apcupsd-3.8.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/apcupsd/apcupsd-3.8.5.ebuild b/sys-apps/apcupsd/apcupsd-3.8.5.ebuild
new file mode 100644
index 000000000000..b5e21a3c254f
--- /dev/null
+++ b/sys-apps/apcupsd/apcupsd-3.8.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/apcupsd-3.8.5.ebuild,v 1.1 2002/08/12 18:20:57 phoenix Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+SRC_URI="http://www.sibbald.com/apcupsd/download/${P}.tar.gz"
+HOMEPAGE="http://www.sibbald.com/apcupsd/"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure || die
+ make || die
+}
+
+src_install () {
+ dosbin apcupsd apcaccess apcnetd
+ cd ${S}/etc
+ dodir etc/apcupsd
+ insinto etc/apcupsd
+ doins *.conf
+ exeinto etc/apcupsd
+ doexe changeme commfailure commok mainsback onbattery
+ doexe ${FILESDIR}/apccontrol
+ dodir var/log/apcupsd
+ sed -e "s:/etc/apcupsd:/var/log/apcupsd:g" ${D}/etc/apcupsd/apcupsd.conf > ${D}/etc/apcupsd/apcupsd.conf.tmp
+ mv ${D}/etc/apcupsd/apcupsd.conf.tmp ${D}/etc/apcupsd/apcupsd.conf
+ cd ${S}/doc
+ dodoc *
+ docinto developers
+ dodoc developers/*
+ docinto manual
+ dodoc manual/*
+ mv ${S}/doc/apcupsd.man ${S}/doc/apcupsd.8
+ doman apcupsd.8
+ dodir /etc/init.d
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/apcupsd
+ doexe ${FILESDIR}/halt
+}