summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-04-13 15:17:14 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-04-13 15:17:14 +0000
commite45fd21f2e9b0a516ff3c974ee1432a0579ac9fd (patch)
tree65ccb4675a23539df6da0c0734cb0fc28982fbd1 /sys-apps/attr/attr-2.4.1.ebuild
parentversion bump to a cvs snapshot (diff)
downloadgentoo-2-e45fd21f2e9b0a516ff3c974ee1432a0579ac9fd.tar.gz
gentoo-2-e45fd21f2e9b0a516ff3c974ee1432a0579ac9fd.tar.bz2
gentoo-2-e45fd21f2e9b0a516ff3c974ee1432a0579ac9fd.zip
version bump to a cvs snapshot
Diffstat (limited to 'sys-apps/attr/attr-2.4.1.ebuild')
-rw-r--r--sys-apps/attr/attr-2.4.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-2.4.1.ebuild b/sys-apps/attr/attr-2.4.1.ebuild
new file mode 100644
index 000000000000..41f158a692fd
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.1.ebuild,v 1.1 2003/04/13 15:17:11 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ mirror://gentoo/${P}-gentoo-suse-copy.patch.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~mips"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+# epatch ${WORKDIR}/${P}-gentoo-suse-copy.patch
+ if [ -z "`use nls`" ]
+ then
+ epatch ${FILESDIR}/${P}-gettext.diff
+ sed -i "s: po::" Makefile
+ fi
+}
+
+src_compile() {
+ OPTIMIZER="${CFLAGS}"
+ DEBUG=-DNDEBUG
+
+ autoconf || die
+
+ econf || die
+
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e 's:-O1::' -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs
+
+ make || die
+}
+
+src_install() {
+ make DIST_ROOT=${D} \
+ install install-lib install-dev || die
+
+ dodir /lib
+ dosym /usr/lib/libattr.a /lib/libattr.a
+ dosym /usr/lib/libattr.la /lib/libattr.la
+ dosym /lib/libattr.so /usr/lib/libattr.so
+ dosym libattr.so.1 /usr/lib/libattr.so
+}