summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:29 +0000
commit569c5419e7efedcfc13d63e0e28992da60019956 (patch)
treed6e54c836968a2611f39c264bb55d1e16360a95c /sys-apps/attr
parentfix-up :) (diff)
downloadgentoo-2-569c5419e7efedcfc13d63e0e28992da60019956.tar.gz
gentoo-2-569c5419e7efedcfc13d63e0e28992da60019956.tar.bz2
gentoo-2-569c5419e7efedcfc13d63e0e28992da60019956.zip
lots of new xfs stuff
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/attr-1.1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-1.1.3.ebuild b/sys-apps/attr/attr-1.1.3.ebuild
new file mode 100644
index 000000000000..3f035448b925
--- /dev/null
+++ b/sys-apps/attr/attr-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-1.1.3.ebuild,v 1.1 2001/11/17 08:37:29 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}