summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
commitb795ef40f29871a83d01839ee8ad432968396763 (patch)
treea61528cb587cc81b06df6960f98eafdf2f236a84 /sys-apps/bash
parentcute little gnome-vfs fix (diff)
downloadgentoo-2-b795ef40f29871a83d01839ee8ad432968396763.tar.gz
gentoo-2-b795ef40f29871a83d01839ee8ad432968396763.tar.bz2
gentoo-2-b795ef40f29871a83d01839ee8ad432968396763.zip
Prepared for rc3
Diffstat (limited to 'sys-apps/bash')
-rw-r--r--sys-apps/bash/bash-2.04.ebuild31
1 files changed, 23 insertions, 8 deletions
diff --git a/sys-apps/bash/bash-2.04.ebuild b/sys-apps/bash/bash-2.04.ebuild
index f21139216e9f..fd453b34b602 100644
--- a/sys-apps/bash/bash-2.04.ebuild
+++ b/sys-apps/bash/bash-2.04.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04.ebuild,v 1.5 2000/10/04 13:31:05 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.04.ebuild,v 1.6 2000/11/30 23:14:31 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -16,10 +16,19 @@ src_compile() {
cd ${S}
try ./configure --prefix=/ --host=${CHOST} \
--disable-profiling --with-curses \
- --enable-static-link
+ --enable-static-link --with-installed-readline
cp Makefile Makefile.orig
sed -e "s:-lcurses:-lncurses:" Makefile.orig > Makefile
- try make
+ try pmake
+ if [ "`use tex`" ]
+ then
+ cd support
+ cp texi2html texi2html.orig
+ sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
+ texi2html.orig > texi2html
+ cd ../doc
+ try make
+ fi
}
@@ -28,14 +37,20 @@ src_compile() {
src_install() {
cd ${S}
- cp doc/bashref.info doc/bash.info
- into /usr
- doinfo doc/bash.info
- doman doc/*.1
+ if [ "`use tex`" ]
+ then
+ docinto html
+ dodoc doc/*.html
+ docinto ps
+ dodoc doc/*.ps
+ fi
into /
dobin bash bashbug
dosym bash /bin/sh
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K doc/FAQ doc/INTRO
+ docinto /
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ docinto txt
+ dodoc doc/FAQ doc/INTRO
}