summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-27 08:07:27 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-27 08:07:27 +0000
commit12efb2c934da0012f77d2f8d552ac9ca07458e5a (patch)
tree8ea71bdaac95d94c9513d1f69c840ae0ed53b2d4 /sys-apps/busybox
parentinstall fixed if IUSE efi for both sub-versions, thx to lejonet and Zorry wrt... (diff)
downloadgentoo-2-12efb2c934da0012f77d2f8d552ac9ca07458e5a.tar.gz
gentoo-2-12efb2c934da0012f77d2f8d552ac9ca07458e5a.tar.bz2
gentoo-2-12efb2c934da0012f77d2f8d552ac9ca07458e5a.zip
Use newexe rather than newins for the udhcpc script as pointed out by Mandeep Singh Baines in ChromiumOS.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog7
-rw-r--r--sys-apps/busybox/busybox-1.21.0.ebuild6
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 843d0197ba67..fd6403121260 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.341 2013/02/27 05:44:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.342 2013/02/27 08:07:27 vapier Exp $
+
+ 27 Feb 2013; Mike Frysinger <vapier@gentoo.org> busybox-1.21.0.ebuild,
+ busybox-9999.ebuild:
+ Use newexe rather than newins for the udhcpc script as pointed out by Mandeep
+ Singh Baines in ChromiumOS.
27 Feb 2013; Mike Frysinger <vapier@gentoo.org> busybox-1.21.0.ebuild,
busybox-9999.ebuild:
diff --git a/sys-apps/busybox/busybox-1.21.0.ebuild b/sys-apps/busybox/busybox-1.21.0.ebuild
index 2a94485712f1..48cfdf96be9c 100644
--- a/sys-apps/busybox/busybox-1.21.0.ebuild
+++ b/sys-apps/busybox/busybox-1.21.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.21.0.ebuild,v 1.7 2013/02/27 05:44:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.21.0.ebuild,v 1.8 2013/02/27 08:07:27 vapier Exp $
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -231,8 +231,8 @@ src_install() {
fi
if busybox_config_enabled UDHCPC; then
local path=$(busybox_config_enabled UDHCPC_DEFAULT_SCRIPT)
- insinto "${path%/*}"
- newins examples/udhcp/simple.script "${path##*/}"
+ exeinto "${path%/*}"
+ newexe examples/udhcp/simple.script "${path##*/}"
fi
if busybox_config_enabled UDHCPD; then
insinto /etc
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index a5b7eb34005c..a1d5c9e22bf7 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.13 2013/02/27 05:44:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.14 2013/02/27 08:07:27 vapier Exp $
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -231,8 +231,8 @@ src_install() {
fi
if busybox_config_enabled UDHCPC; then
local path=$(busybox_config_enabled UDHCPC_DEFAULT_SCRIPT)
- insinto "${path%/*}"
- newins examples/udhcp/simple.script "${path##*/}"
+ exeinto "${path%/*}"
+ newexe examples/udhcp/simple.script "${path##*/}"
fi
if busybox_config_enabled UDHCPD; then
insinto /etc