summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-09-11 08:08:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-09-11 08:08:42 +0000
commit64bb06d628160bda2ec6515c993eb14130bcaac9 (patch)
tree59a51e9b5e27ae29e0b51554a6e647d261d74a08 /sys-apps/busybox
parentversion bump - ebuild and patch supplied by Aaron Walker via bug #48477 (Mani... (diff)
downloadgentoo-2-64bb06d628160bda2ec6515c993eb14130bcaac9.tar.gz
gentoo-2-64bb06d628160bda2ec6515c993eb14130bcaac9.tar.bz2
gentoo-2-64bb06d628160bda2ec6515c993eb14130bcaac9.zip
Fixed saveconfig and make-busybox-symlinks as per bugs #60982 and #60805.
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog8
-rw-r--r--sys-apps/busybox/busybox-1.00_pre8.ebuild22
-rw-r--r--sys-apps/busybox/busybox-1.00_rc3.ebuild19
3 files changed, 37 insertions, 12 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index d83bb59fe87b..7e43018323ef 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.41 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.42 2004/09/11 08:08:42 dragonheart Exp $
+
+ 11 Sep 2004; Daniel Black <dragonheart@gentoo.org> busybox-1.00_pre8.ebuild,
+ busybox-1.00_rc3.ebuild:
+ Fixed saveconfig and make-busybox-symlinks as per bugs #60982 and #60805.
+ Thanks to Edward Flick <eddy@cdf-imaging.com> and Dirk Heinrichs
+ <ext-dirk.heinrichs@nokia.com>
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
busybox-1.00_pre8.ebuild, busybox-1.00_rc3.ebuild:
diff --git a/sys-apps/busybox/busybox-1.00_pre8.ebuild b/sys-apps/busybox/busybox-1.00_pre8.ebuild
index 3b2c0836192d..75519afc6477 100644
--- a/sys-apps/busybox/busybox-1.00_pre8.ebuild
+++ b/sys-apps/busybox/busybox-1.00_pre8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_pre8.ebuild,v 1.11 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_pre8.ebuild,v 1.12 2004/09/11 08:08:42 dragonheart Exp $
inherit eutils
@@ -48,14 +48,15 @@ src_unpack() {
if use savedconfig ; then
[ -r .config ] && rm .config
- for conf in {${PN}-${PV}-${PR},${PN}-${PV},${PN}}.config; do
- if [ -r /etc/${PN}/${CCHOST}/${conf} ]; then
- cp /etc/${PN}/${CCHOST}/${conf} ${S}/.config
+ for conf in ${PN}-${PV}-${PR} ${PN}-${PV} ${PN}; do
+ configfile=/etc/${PN}/${CCHOST}/${conf}.config
+ if [ -r ${configfile} ]; then
+ cp ${configfile} ${S}/.config
break;
fi
done
if [ -r "${S}/.config" ]; then
- einfo "Found your /etc/${PN}/${CCHOST}/${conf} and using it."
+ einfo "Found your ${configfile} and using it."
return 0
fi
fi
@@ -135,7 +136,16 @@ src_install() {
into /
dobin busybox
- if use make-busybox-symlinks ; then
+ if use make-busybox-symlinks ;
+ then
+ if [ ! "${VERY_BRAVE_OR_VERY_DUMB}" = "yes" ] && [ "${ROOT}" = "/" ];
+ then
+ ewarn "setting USE=make-busybox-symlinks and emerging to / is very dangerous."
+ ewarn "It WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
make CROSS="${CROSS}" install || die
dodir /bin
cp -a _install/bin/* ${D}/bin/
diff --git a/sys-apps/busybox/busybox-1.00_rc3.ebuild b/sys-apps/busybox/busybox-1.00_rc3.ebuild
index 7778c73063c1..ad8d2ee78c64 100644
--- a/sys-apps/busybox/busybox-1.00_rc3.ebuild
+++ b/sys-apps/busybox/busybox-1.00_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_rc3.ebuild,v 1.4 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_rc3.ebuild,v 1.5 2004/09/11 08:08:42 dragonheart Exp $
inherit eutils
@@ -59,14 +59,15 @@ src_unpack() {
if use savedconfig ; then
[ -r .config ] && rm .config
- for conf in {${PN}-${PV}-${PR},${PN}-${PV},${PN}}.config; do
- if [ -r /etc/${PN}/${CCHOST}/${conf} ]; then
- cp /etc/${PN}/${CCHOST}/${conf} ${S}/.config
+ for conf in ${PN}-${PV}-${PR} ${PN}-${PV} ${PN}; do
+ configfile=/etc/${PN}/${CCHOST}/${conf}.config
+ if [ -r ${configfile} ]; then
+ cp ${configfile} ${S}/.config
break;
fi
done
if [ -r "${S}/.config" ]; then
- einfo "Found your /etc/${PN}/${CCHOST}/${conf} and using it."
+ einfo "Found your ${configfile} and using it."
return 0
fi
fi
@@ -154,6 +155,14 @@ src_install() {
into /
dobin busybox
if use make-busybox-symlinks ; then
+ if [ ! "${VERY_BRAVE_OR_VERY_DUMB}" = "yes" ] && [ "${ROOT}" = "/" ];
+ then
+ ewarn "setting USE=make-busybox-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
make CROSS="${CROSS}" install || die
dodir /bin
cp -a _install/bin/* ${D}/bin/