summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-28 06:00:19 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-28 06:00:19 +0000
commit697c15724132b6bdcab0a2f797cf98c9ed9905e5 (patch)
treea817ec54bfee5b5f488c1ce5671c71dc02aaf340 /sys-apps/busybox
parentwhitespace (diff)
downloadgentoo-2-697c15724132b6bdcab0a2f797cf98c9ed9905e5.tar.gz
gentoo-2-697c15724132b6bdcab0a2f797cf98c9ed9905e5.tar.bz2
gentoo-2-697c15724132b6bdcab0a2f797cf98c9ed9905e5.zip
set the config static flag on the cmdline rather than forcing LDFLAGS #160879
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.4.1-r2.ebuild4
-rw-r--r--sys-apps/busybox/busybox-1.4.2.ebuild4
-rw-r--r--sys-apps/busybox/busybox-1.5.0.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/busybox/busybox-1.4.1-r2.ebuild b/sys-apps/busybox/busybox-1.4.1-r2.ebuild
index 4760438af9d4..612baf7be2a2 100644
--- a/sys-apps/busybox/busybox-1.4.1-r2.ebuild
+++ b/sys-apps/busybox/busybox-1.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r2.ebuild,v 1.8 2007/03/25 16:29:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r2.ebuild,v 1.9 2007/03/28 06:00:19 vapier Exp $
inherit eutils flag-o-matic
@@ -183,7 +183,7 @@ src_compile() {
emake busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
- LDFLAGS="${LDFLAGS} -static" emake busybox || die "static build failed"
+ emake CONFIG_STATIC=y busybox || die "static build failed"
mv busybox_unstripped bb
mv busybox_unstripped{.bak,}
fi
diff --git a/sys-apps/busybox/busybox-1.4.2.ebuild b/sys-apps/busybox/busybox-1.4.2.ebuild
index 6d59ad6c9d2f..58cdef3bd707 100644
--- a/sys-apps/busybox/busybox-1.4.2.ebuild
+++ b/sys-apps/busybox/busybox-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.2.ebuild,v 1.2 2007/03/25 16:29:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.2.ebuild,v 1.3 2007/03/28 06:00:19 vapier Exp $
inherit eutils flag-o-matic
@@ -181,7 +181,7 @@ src_compile() {
emake busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
- LDFLAGS="${LDFLAGS} -static" emake busybox || die "static build failed"
+ emake CONFIG_STATIC=y busybox || die "static build failed"
mv busybox_unstripped bb
mv busybox_unstripped{.bak,}
fi
diff --git a/sys-apps/busybox/busybox-1.5.0.ebuild b/sys-apps/busybox/busybox-1.5.0.ebuild
index 473a6fba6389..0d65689e7b67 100644
--- a/sys-apps/busybox/busybox-1.5.0.ebuild
+++ b/sys-apps/busybox/busybox-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.5.0.ebuild,v 1.1 2007/03/25 15:00:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.5.0.ebuild,v 1.2 2007/03/28 06:00:19 vapier Exp $
inherit eutils flag-o-matic
@@ -180,7 +180,7 @@ src_compile() {
emake busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
- LDFLAGS="${LDFLAGS} -static" emake busybox || die "static build failed"
+ emake CONFIG_STATIC=y busybox || die "static build failed"
mv busybox_unstripped bb
mv busybox_unstripped{.bak,}
fi