summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-05-13 01:51:35 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-05-13 01:51:35 +0000
commiteac5f1ddf6527ce8beedcb114bc55e22cf0ae4f7 (patch)
tree211f3019b5a0d40377c7c01cabcb769af9fbbf84 /sys-apps/coreutils-darwin
parentuse, dont need, logger #92406 (diff)
downloadgentoo-2-eac5f1ddf6527ce8beedcb114bc55e22cf0ae4f7.tar.gz
gentoo-2-eac5f1ddf6527ce8beedcb114bc55e22cf0ae4f7.tar.bz2
gentoo-2-eac5f1ddf6527ce8beedcb114bc55e22cf0ae4f7.zip
Added fix for 10.4.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-apps/coreutils-darwin')
-rw-r--r--sys-apps/coreutils-darwin/ChangeLog6
-rw-r--r--sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild17
2 files changed, 16 insertions, 7 deletions
diff --git a/sys-apps/coreutils-darwin/ChangeLog b/sys-apps/coreutils-darwin/ChangeLog
index 2dc4f9cb41ef..9e4a106fb889 100644
--- a/sys-apps/coreutils-darwin/ChangeLog
+++ b/sys-apps/coreutils-darwin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils-darwin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.2 2005/05/12 20:03:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/ChangeLog,v 1.3 2005/05/13 01:51:35 josejx Exp $
+
+ 13 May 2005; Joseph Jezak <josejx@gentoo.org>
+ coreutils-darwin-5.3.0.ebuild:
+ Added fix for 10.4
*coreutils-darwin-5.3.0 (12 May 2005)
diff --git a/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
index 3d8b3b1aab65..1b93deae1bab 100644
--- a/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
+++ b/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild,v 1.1 2005/05/12 20:03:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils-darwin/coreutils-darwin-5.3.0.ebuild,v 1.2 2005/05/13 01:51:35 josejx Exp $
+
+inherit eutils
DESCRIPTION="Standard GNU file utilities, text utilities, and shell utilities missing from Darwin."
HOMEPAGE="http://www.gnu.org/software/coreutils/"
@@ -32,6 +34,7 @@ EXISTINGBIN="cat chmod cp date dd df echo expr ln ls mkdir mv pwd rm rmdir sleep
EXISTINGUSBIN="chown chroot"
EXISTINGSBIN="mknod"
DONTLINK="[ kill hostname"
+TENFOUR="link unlink csplit nl pathchk"
src_compile() {
cd ${S}
@@ -40,12 +43,10 @@ src_compile() {
--bindir=/bin \
`use_enable nls` || die
- if use static
- then
- emake LDFLAGS="${LDFLAGS} -static" || die
- else
- emake || die
+ if use static; then
+ append-ldflags -static
fi
+ emake || die
}
src_install() {
@@ -59,6 +60,10 @@ src_install() {
rm -rf usr/lib
cd bin
+ if [ "$MACOSX_DEPOYMENT_TARGET" == "10.4" ]; then
+ rm ${TENFOUR}
+ fi
+
rm ${EXISTINGBIN} ${EXISTINGUSR} ${EXISTINGUSBIN} ${EXISTINGSBIN} ${DONTLINK}
# Move the non-critical pacakges to /usr/bin