summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-08 00:32:10 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-08 00:32:10 +0000
commitc459669ad05c563675e60dc7fa083e0aec90c5b7 (patch)
tree17aa139f2acc2e657986d40919d796183c1507b0 /sys-apps/coreutils
parentStable on ppc wrt bug #153218 (diff)
downloadgentoo-2-c459669ad05c563675e60dc7fa083e0aec90c5b7.tar.gz
gentoo-2-c459669ad05c563675e60dc7fa083e0aec90c5b7.tar.bz2
gentoo-2-c459669ad05c563675e60dc7fa083e0aec90c5b7.zip
Version bump.
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-6.7.ebuild150
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-6.76
3 files changed, 162 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 7182a29706c7..fbddccc3acf4 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.186 2006/12/01 16:13:49 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.187 2006/12/08 00:32:10 vapier Exp $
+
+*coreutils-6.7 (08 Dec 2006)
+
+ 08 Dec 2006; Mike Frysinger <vapier@gentoo.org> +coreutils-6.7.ebuild:
+ Version bump.
01 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
coreutils-6.4.ebuild:
diff --git a/sys-apps/coreutils/coreutils-6.7.ebuild b/sys-apps/coreutils/coreutils-6.7.ebuild
new file mode 100644
index 000000000000..0f438885c6b9
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-6.7.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.7.ebuild,v 1.1 2006/12/08 00:32:10 vapier Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+PATCH_VER="1.0"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl nls selinux static"
+RESTRICT="confcache"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( >=sys-devel/gettext-0.15 )
+ !net-mail/base64
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ =sys-devel/automake-1.9*
+ >=sys-devel/autoconf-2.59d
+ >=sys-devel/m4-1.4-r1
+ sys-apps/help2man"
+
+pkg_setup() {
+ # fixup expr for #123342
+ if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
+ if [[ -x /bin/busybox ]] ; then
+ ln -sf /bin/busybox /bin/expr
+ else
+ eerror "Your expr binary appears to be broken, please fix it."
+ eerror "For more info, see http://bugs.gentoo.org/123342"
+ die "your expr is broke"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ PATCHDIR="${WORKDIR}/patch"
+ rm -f "${PATCHDIR}"/generic/001_*progress*
+
+ # Apply the ACL/SELINUX patches.
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
+ else
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ chmod a+rx tests/sort/sort-mb-tests
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+ # There's no reason for this crap to use the private version
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --bindir=/usr/libexec/gnu"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] \
+ && myconf="${myconf} --without-included-regex"
+
+ use static && append-ldflags -static
+ econf \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable acl) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+ emake || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/usr/lib/charset.alias
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ else
+ # For now, drop the man pages, collides with the ones of the system.
+ rm -rf "${D}"/usr/share/man
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-6.7 b/sys-apps/coreutils/files/digest-coreutils-6.7
new file mode 100644
index 000000000000..bd0efe468b7b
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-6.7
@@ -0,0 +1,6 @@
+MD5 4e491d77b463c13c8054150dcce84e6b coreutils-6.7-patches-1.0.tar.bz2 32171
+RMD160 431ee64bfb8ec89f460b199aa3a42994d51ad990 coreutils-6.7-patches-1.0.tar.bz2 32171
+SHA256 8e665c1008514dc50795aaa02e26710812337c6a1704da31242af9cef8d8004c coreutils-6.7-patches-1.0.tar.bz2 32171
+MD5 a16465d0856cd011a1acc1c21040b7f4 coreutils-6.7.tar.bz2 5315342
+RMD160 593acd266431db1777505bd181a7ffe095774beb coreutils-6.7.tar.bz2 5315342
+SHA256 4d7027cc803682decdadf850095dce7e22cc08eba2b1283e16d0fb7a675ac1f0 coreutils-6.7.tar.bz2 5315342