summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-05-20 19:41:56 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-05-20 19:41:56 +0000
commitbfcfc6210ed2aabc2a703fcd9e176d932b79c443 (patch)
tree85283285f76e855e5c6ed93ed23bc04567b70710 /sys-apps/dcron/dcron-2.9.ebuild
parentdebian project say its okay to mirror libots. (diff)
downloadgentoo-2-bfcfc6210ed2aabc2a703fcd9e176d932b79c443.tar.gz
gentoo-2-bfcfc6210ed2aabc2a703fcd9e176d932b79c443.tar.bz2
gentoo-2-bfcfc6210ed2aabc2a703fcd9e176d932b79c443.zip
Removing gcc hardcode
Diffstat (limited to 'sys-apps/dcron/dcron-2.9.ebuild')
-rw-r--r--sys-apps/dcron/dcron-2.9.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-apps/dcron/dcron-2.9.ebuild b/sys-apps/dcron/dcron-2.9.ebuild
index aa13bacbc2ff..a92b71abfb45 100644
--- a/sys-apps/dcron/dcron-2.9.ebuild
+++ b/sys-apps/dcron/dcron-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9.ebuild,v 1.2 2003/04/16 14:33:46 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9.ebuild,v 1.3 2003/05/20 19:41:48 taviso Exp $
# to use this, you must be part of the "cron" group
@@ -9,7 +9,7 @@ S=${WORKDIR}/${PN}
DESCRIPTION="A cute little cron from Matt Dillon"
SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
HOMEPAGE="http://apollo.backplane.com/"
-KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa alpha"
SLOT="0"
LICENSE="GPL-2"
@@ -30,6 +30,9 @@ src_unpack() {
sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
cp ${S}/crontab.1 ${S}/crontab.1.orig
sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # remove gcc hardcode
+ cp ${S}/Makefile ${S}/Makefile.orig
+ sed -e "s:\(CC = \)gcc:\1${CC:-gcc}:" ${S}/Makefile.orig > ${S}/Makefile
}
src_compile() {