summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-05-18 23:13:44 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-05-18 23:13:44 +0000
commita5eb3bae08c9a1db9004e6d6e12df50a389ec27c (patch)
treec95d796cab2d774517d3ea3d9b79d7f81d7736dd /sys-apps/debianutils
parentfix gcc-3.3 issues (diff)
downloadgentoo-2-a5eb3bae08c9a1db9004e6d6e12df50a389ec27c.tar.gz
gentoo-2-a5eb3bae08c9a1db9004e6d6e12df50a389ec27c.tar.bz2
gentoo-2-a5eb3bae08c9a1db9004e6d6e12df50a389ec27c.zip
fix gcc-3.3 issues
Diffstat (limited to 'sys-apps/debianutils')
-rw-r--r--sys-apps/debianutils/ChangeLog8
-rw-r--r--sys-apps/debianutils/Manifest6
-rw-r--r--sys-apps/debianutils/debianutils-1.16.7-r2.ebuild67
-rw-r--r--sys-apps/debianutils/files/debianutils-1.16.7-gcc33.patch53
-rw-r--r--sys-apps/debianutils/files/digest-debianutils-1.16.7-r21
5 files changed, 131 insertions, 4 deletions
diff --git a/sys-apps/debianutils/ChangeLog b/sys-apps/debianutils/ChangeLog
index 8ae81c915ced..ef4aa457f2a8 100644
--- a/sys-apps/debianutils/ChangeLog
+++ b/sys-apps/debianutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/debianutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.17 2003/04/12 14:48:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.18 2003/05/18 23:11:40 azarah Exp $
+
+*debianutils-1.16.7-r2 (19 May 2003)
+
+ 19 May 2003; Martin Schlemmer <azarah@gentoo.org>
+ debianutils-1.16.7-r2.ebuild, files/debianutils-1.16.7-gcc33.patch:
+ Fix gcc-3.3 issue, bug #21211.
*debianutils-1.16.7-r1 (03 Apr 2003)
diff --git a/sys-apps/debianutils/Manifest b/sys-apps/debianutils/Manifest
index aff06afc0a70..53e195aced0e 100644
--- a/sys-apps/debianutils/Manifest
+++ b/sys-apps/debianutils/Manifest
@@ -1,8 +1,8 @@
-MD5 736813037dbaa471c078c80c6cf7f9f2 ChangeLog 2976
+MD5 e2055c6d288204d0561eb39df26d7e0e ChangeLog 3169
MD5 f9dcd526351d07019453588417ac7f7a debianutils-1.16.7-r1.ebuild 1351
-MD5 4f6662203c327ed487cc40381714c5c1 debianutils-1.16.7-r2.ebuild 1465
+MD5 629cadd8d7861d1e107f3a69641b1ac7 debianutils-1.16.7-r2.ebuild 1463
MD5 f668f7cf3760bd5f131cec5de5602523 files/digest-debianutils-1.16.7-r1 69
-MD5 58bd0cbdd38be3e8410be2bccff4b50b files/debianutils-1.16.7-gcc33.patch 2907
+MD5 a497960da56a8ef8cb07158e15407c18 files/debianutils-1.16.7-gcc33.patch 2588
MD5 f668f7cf3760bd5f131cec5de5602523 files/digest-debianutils-1.16.7-r2 69
MD5 3f67e66ea1d7aa13843f253310322f51 files/debianutils-compress.patch 743
MD5 e814d4dcbe42ad46f0fa3449b653c173 files/debianutils-1.16.7-gentoo.patch 7521
diff --git a/sys-apps/debianutils/debianutils-1.16.7-r2.ebuild b/sys-apps/debianutils/debianutils-1.16.7-r2.ebuild
new file mode 100644
index 000000000000..1bb88151d40e
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-1.16.7-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.7-r2.ebuild,v 1.1 2003/05/18 23:11:40 azarah Exp $
+
+IUSE="static build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="http://packages.debian.org/unstable/base/debianutils.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="sys-apps/bzip2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Make installkernel and mkboot more Gentoo friendly
+ # <azarah@gentoo.org> (25 Sep 2002)
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ # Patch savelog to use bzip2 compression instead of gzip
+ epatch ${FILESDIR}/${PN}-compress.patch
+
+ # Get it to work with gcc-3.3
+ # <azarah@gentoo.org> (18 May 2003)
+ epatch ${FILESDIR}/${P}-gcc33.patch
+}
+
+src_compile() {
+ if [ -z "`use static`" ]
+ then
+ pmake || die
+ else
+ pmake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ into /
+ dobin readlink tempfile mktemp
+
+ if [ -z "`use build`" ]
+ then
+ dobin run-parts
+ insopts -m755
+ exeinto /usr/sbin
+ doexe savelog
+ dosbin installkernel
+ into /usr
+ dosbin mkboot
+
+ into /usr
+ doman mktemp.1 readlink.1 tempfile.1 run-parts.8 savelog.8 \
+ installkernel.8 mkboot.8
+
+ cd debian
+ dodoc changelog control copyright
+ fi
+}
diff --git a/sys-apps/debianutils/files/debianutils-1.16.7-gcc33.patch b/sys-apps/debianutils/files/debianutils-1.16.7-gcc33.patch
new file mode 100644
index 000000000000..66e23558f3ad
--- /dev/null
+++ b/sys-apps/debianutils/files/debianutils-1.16.7-gcc33.patch
@@ -0,0 +1,53 @@
+diff -urpN debianutils-1.16.7/run-parts.c debianutils-1.16.7.azarah/run-parts.c
+--- debianutils-1.16.7/run-parts.c 2003-05-19 00:54:27.000000000 +0200
++++ debianutils-1.16.7.azarah/run-parts.c 2003-05-19 00:57:02.000000000 +0200
+@@ -55,10 +55,10 @@ void error (char *format,...)
+ void version ()
+ {
+ fprintf (stderr, "Debian GNU/Linux run-parts program, version " VERSION
+-"\nCopyright (C) 1994 Ian Jackson, Copyright (C) 1996 Jeff Noxon.
+-Copyright (C) 1996,1997,1998,1999 Guy Maor
+-This is free software; see the GNU General Public License version 2
+-or later for copying conditions. There is NO warranty.
++"\nCopyright (C) 1994 Ian Jackson, Copyright (C) 1996 Jeff Noxon.\n\
++Copyright (C) 1996,1997,1998,1999 Guy Maor\n\
++This is free software; see the GNU General Public License version 2\n\
++or later for copying conditions. There is NO warranty.\n\
+ ");
+ exit (0);
+ }
+@@ -66,14 +66,14 @@ or later for copying conditions. There
+
+ void usage ()
+ {
+- fprintf (stderr, "Usage: run-parts [OPTION]... DIRECTORY
+- --test print script names which would run, but don't run them.
+- --verbose print script names before running them.
+- --report print script names if they produce output.
+- --umask=UMASK sets umask to UMASK (octal), default is 022.
+- --arg=ARGUMENT pass ARGUMENT to scripts, use once for each argument.
+- --version output version information and exit.
+- --help display this help and exit.
++ fprintf (stderr, "Usage: run-parts [OPTION]... DIRECTORY\n\
++ --test print script names which would run, but don't run them.\n\
++ --verbose print script names before running them.\n\
++ --report print script names if they produce output.\n\
++ --umask=UMASK sets umask to UMASK (octal), default is 022.\n\
++ --arg=ARGUMENT pass ARGUMENT to scripts, use once for each argument.\n\
++ --version output version information and exit.\n\
++ --help display this help and exit.\n\
+ ");
+ exit(0);
+ }
+diff -urpN debianutils-1.16.7/tempfile.c debianutils-1.16.7.azarah/tempfile.c
+--- debianutils-1.16.7/tempfile.c 2002-09-28 21:17:03.000000000 +0200
++++ debianutils-1.16.7.azarah/tempfile.c 2003-05-19 00:57:15.000000000 +0200
+@@ -17,7 +17,7 @@ usage (int status)
+ fprintf(stderr, "Try `%s --help' for more information.\n", progname);
+ else
+ printf("Usage: %s [OPTION]\n\
+-Create a temporary file in a safe manner.
++Create a temporary file in a safe manner.\n\
+ \n\
+ -d, --directory=DIR place temporary file in DIR\n\
+ -p, --prefix=STRING set temporary file's prefix to STRING\n\
diff --git a/sys-apps/debianutils/files/digest-debianutils-1.16.7-r2 b/sys-apps/debianutils/files/digest-debianutils-1.16.7-r2
new file mode 100644
index 000000000000..43e9c44d417a
--- /dev/null
+++ b/sys-apps/debianutils/files/digest-debianutils-1.16.7-r2
@@ -0,0 +1 @@
+MD5 7ff426c92daf7fab4d19dcec81f27800 debianutils_1.16.7.tar.gz 26097