summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-04-09 18:36:17 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-04-09 18:36:17 +0000
commit8b231c59e14a6b746f402500aa65b537cbbd3694 (patch)
tree08316943718640ce2a1ea992b4d6f4b682883f62 /sys-apps/dmtcp/files
parentFix pcheck warn nonexistant atoms (diff)
downloadgentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.tar.gz
gentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.tar.bz2
gentoo-2-8b231c59e14a6b746f402500aa65b537cbbd3694.zip
Updated with QA fixes and a gcc 4.6 patch. That was quick...
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dmtcp/files')
-rw-r--r--sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch b/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch
new file mode 100644
index 000000000000..fd013e3b6ae7
--- /dev/null
+++ b/sys-apps/dmtcp/files/dmtcp-1.2.1-gcc46.patch
@@ -0,0 +1,21 @@
+--- a/dmtcp/src/Makefile.am
++++ b/dmtcp/src/Makefile.am
+@@ -66,7 +66,7 @@
+
+ dmtcp_inspector_SOURCES = dmtcp_inspector.cpp
+
+-dmtcphijack_so_LDFLAGS = -shared -avoid-version -module
++dmtcphijack_so_LDFLAGS = -shared -module
+
+ #dmtcp_nocheckpoint_LDFLAGS = -static
+
+--- a/dmtcp/src/dmtcpalloc.h
++++ b/dmtcp/src/dmtcpalloc.h
+@@ -33,6 +33,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <fstream>
++#include <cstddef>
+
+ #define DMTCPSTRING dmtcp::string
+ #define DMTCPVECTOR(T) dmtcp::vector<T>