summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-11-04 19:41:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-11-04 19:41:55 +0000
commit49c2f3579b3d000a41238f7a6fb5f5f2e6a4e615 (patch)
tree9c093cb6cedab2866565faa6ce0178f91d9d076e /sys-apps/etckeeper
parentCleanup old versions. (diff)
downloadgentoo-2-49c2f3579b3d000a41238f7a6fb5f5f2e6a4e615.tar.gz
gentoo-2-49c2f3579b3d000a41238f7a6fb5f5f2e6a4e615.tar.bz2
gentoo-2-49c2f3579b3d000a41238f7a6fb5f5f2e6a4e615.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sys-apps/etckeeper')
-rw-r--r--sys-apps/etckeeper/ChangeLog7
-rw-r--r--sys-apps/etckeeper/etckeeper-1.10.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/etckeeper/ChangeLog b/sys-apps/etckeeper/ChangeLog
index fc2de45c5272..5aedbbc26f8f 100644
--- a/sys-apps/etckeeper/ChangeLog
+++ b/sys-apps/etckeeper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/etckeeper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/etckeeper/ChangeLog,v 1.32 2013/10/29 22:09:25 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/etckeeper/ChangeLog,v 1.33 2013/11/04 19:41:55 hasufell Exp $
+
+*etckeeper-1.10 (04 Nov 2013)
+
+ 04 Nov 2013; Julian Ospald <hasufell@gentoo.org> +etckeeper-1.10.ebuild:
+ version bump
29 Oct 2013; Tony Vroon <chainsaw@gentoo.org> etckeeper-1.9.ebuild:
Marked stable on AMD64 based on arch testing by Elijah "Armageddon" El
diff --git a/sys-apps/etckeeper/etckeeper-1.10.ebuild b/sys-apps/etckeeper/etckeeper-1.10.ebuild
new file mode 100644
index 000000000000..e3e38d6fff41
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/etckeeper/etckeeper-1.10.ebuild,v 1.1 2013/11/04 19:41:55 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit eutils bash-completion-r1 prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="http://kitenet.net/~joey/code/etckeeper/"
+SRC_URI="https://github.com/joeyh/etckeeper/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bazaar cron"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${PN}-1.7-gentoo.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ ${PYTHON} ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ newbashcomp bash_completion ${PN}
+ dodoc README TODO
+ docinto examples
+ dodoc "${FILESDIR}"/bashrc
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${P}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}