summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-10-02 09:31:11 +0000
committerDonny Davies <woodchip@gentoo.org>2002-10-02 09:31:11 +0000
commitb72cfd7791979a0abed3d062c903206568759926 (patch)
treec9548b3020215bce9cdef87321885b53cdc827d0 /sys-apps/evms
parentmask new evms-1.2.0 (diff)
downloadgentoo-2-b72cfd7791979a0abed3d062c903206568759926.tar.gz
gentoo-2-b72cfd7791979a0abed3d062c903206568759926.tar.bz2
gentoo-2-b72cfd7791979a0abed3d062c903206568759926.zip
chase latest release
Diffstat (limited to 'sys-apps/evms')
-rw-r--r--sys-apps/evms/ChangeLog10
-rw-r--r--sys-apps/evms/evms-1.2.0.ebuild62
-rw-r--r--sys-apps/evms/files/digest-evms-1.2.01
3 files changed, 71 insertions, 2 deletions
diff --git a/sys-apps/evms/ChangeLog b/sys-apps/evms/ChangeLog
index c8d6481c283f..b59b7d53e9b2 100644
--- a/sys-apps/evms/ChangeLog
+++ b/sys-apps/evms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/evms
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.8 2002/08/27 04:34:35 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/ChangeLog,v 1.9 2002/10/02 09:31:11 woodchip Exp $
+
+*evms-1.2.0 (02 Oct 2002)
+
+ 02 Oct 2002; Donny Davies <woodchip@gentoo.org>: New evms-1.2.0 release
+ which is backwards compatible with 1.1.0 kernel drivers. Now builds
+ independent of /usr/src/linux headers. Thanks lnx1138@us.ibm.com.
*evms-1.1.0 (07 Aug 2002)
@@ -21,7 +27,7 @@
14 Jul 2002; phoen][x <phoenix@gentoo.org> evms-1.0.1.ebuild : Added
KEYWORDS.
- 8 May 2002; Donny Davies <woodchip@gentoo.org>: Updated to 1.0.1.
+ 08 May 2002; Donny Davies <woodchip@gentoo.org>: Updated to 1.0.1.
*evms-1.0.0-r1 (30 Apr 2002)
diff --git a/sys-apps/evms/evms-1.2.0.ebuild b/sys-apps/evms/evms-1.2.0.ebuild
new file mode 100644
index 000000000000..726f6dfc9643
--- /dev/null
+++ b/sys-apps/evms/evms-1.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/evms/evms-1.2.0.ebuild,v 1.1 2002/10/02 09:31:11 woodchip Exp $
+
+DESCRIPTION="Utilities for the IBM Enterprise Volume Management System"
+HOMEPAGE="http://www.sourceforge.net/projects/evms"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.sourceforge.net/pub/sourceforge/${PN}/${P}.tar.gz"
+
+#EVMS uses libuuid from e2fsprogs
+DEPEND="virtual/glibc gtk? ( =x11-libs/gtk+-1* ) ncurses? ( sys-libs/ncurses ) sys-apps/e2fsprogs"
+RDEPEND="${DEPEND}"
+KEYWORDS="x86 -ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local interfaces="CommandLine,utilities"
+ use ncurses && interfaces="ncurses,${interfaces}"
+ use gtk && interfaces="evmsgui,${interfaces}"
+
+ cd engine
+ ./configure \
+ --prefix=/usr \
+ --libdir=/lib \
+ --sbindir=/sbin \
+ --with-plugins=all \
+ --mandir=/usr/share/man \
+ --includedir=/usr/include \
+ --with-interfaces=${interfaces} \
+ --host=${CHOST} || die "bad ./configure"
+ #1.2.0 doesn't support parallel make
+ make || die "compile problem"
+}
+
+src_install() {
+ make -C engine DESTDIR=${D} install || die
+ dodoc CHANGES COPYING EVMS*.txt PLUGIN.IDS
+
+ # move static libraries to /usr/lib
+ dodir /usr/lib
+ mv -f ${D}/lib/*.a ${D}/usr/lib
+
+ # realize these symlinks now so they get included
+ cd ${D}/lib
+ rm -f libdlist.so libevms.so
+ ln -sf libevms-${LIBV}.so libevms.so.1
+ ln -sf libevms.so.1 libevms.so
+ ln -sf libdlist-1.0.so libdlist.so.1
+ ln -sf libdlist.so.1 libdlist.so
+
+ # the gtk+ frontend should live in /usr/sbin
+ if [ -n "`use gtk`" ]
+ then
+ dodir /usr/sbin
+ mv -f ${D}/sbin/evmsgui ${D}/usr/sbin
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/evms-init evms
+}
diff --git a/sys-apps/evms/files/digest-evms-1.2.0 b/sys-apps/evms/files/digest-evms-1.2.0
new file mode 100644
index 000000000000..2559ff7df4a7
--- /dev/null
+++ b/sys-apps/evms/files/digest-evms-1.2.0
@@ -0,0 +1 @@
+MD5 70dde97474eb3ab73f4bed144e3fb849 evms-1.2.0.tar.gz 1885734