summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-01-23 08:03:53 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-01-23 08:03:53 +0000
commitbbed083c40133965a94f87a4c686b5d8e28ecc5c (patch)
treed96ee5069a2fbc93e85514b4f60bce876314c758 /sys-apps/file/file-4.07-r1.ebuild
parentInitial import. Thanks to Alexander Kellett <lypanov@kde.org> for contributin... (diff)
downloadgentoo-2-bbed083c40133965a94f87a4c686b5d8e28ecc5c.tar.gz
gentoo-2-bbed083c40133965a94f87a4c686b5d8e28ecc5c.tar.bz2
gentoo-2-bbed083c40133965a94f87a4c686b5d8e28ecc5c.zip
Added patch to fix endless loop (100% cpu usage) bug found when file'ing certain elf bins (source change found within debian patch)
Diffstat (limited to 'sys-apps/file/file-4.07-r1.ebuild')
-rw-r--r--sys-apps/file/file-4.07-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/file/file-4.07-r1.ebuild b/sys-apps/file/file-4.07-r1.ebuild
new file mode 100644
index 000000000000..5efb8f6989a7
--- /dev/null
+++ b/sys-apps/file/file-4.07-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.07-r1.ebuild,v 1.1 2004/01/23 08:03:53 jhhudso Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~alpha ~hppa ~mips ~ia64 ~ppc64"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-4.07-gentoo.diff
+
+ # (12 Oct 2003) <kumba@gentoo.org>
+ # This patch is for MIPS only. It slightly changes the 'file' output
+ # on MIPS machines to a specific format so that other programs can
+ # recognize things.
+ if [ "${ARCH}" = "mips" ]; then
+ epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.diff
+ fi
+}
+
+src_compile() {
+
+ # If running mips64, we need updated configure data
+ use mips && gnuconfig_update
+
+ # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
+ [ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/misc \
+ --host=${CHOST} || die
+
+ # Buggy Makefiles. This fixes bug 31356
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ if [ -z "`use build`" ] ; then
+ dodoc ChangeLog LEGAL.NOTICE MAINT README || die "dodoc failed"
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}