summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-25 14:29:50 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-25 14:29:50 +0000
commita13930f12a0e2d39fde684a2675c44507e2b9281 (patch)
tree4d7ce0b9392db276eb24694d05d7ad7aea8df6f5 /sys-apps/fileutils/fileutils-4.1.11.ebuild
parentAdded alpha to KEYWORDS (diff)
downloadgentoo-2-a13930f12a0e2d39fde684a2675c44507e2b9281.tar.gz
gentoo-2-a13930f12a0e2d39fde684a2675c44507e2b9281.tar.bz2
gentoo-2-a13930f12a0e2d39fde684a2675c44507e2b9281.zip
new version
Diffstat (limited to 'sys-apps/fileutils/fileutils-4.1.11.ebuild')
-rw-r--r--sys-apps/fileutils/fileutils-4.1.11.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/fileutils/fileutils-4.1.11.ebuild b/sys-apps/fileutils/fileutils-4.1.11.ebuild
new file mode 100644
index 000000000000..86f1d8d1d70a
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.11.ebuild,v 1.1 2002/09/25 14:29:50 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix braindead scripting problem in configure
+ # <azarah@gentoo.org> (25 Sep 2002)
+ patch -p1 < ${FILESDIR}/${P}-configure.patch || die
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --bindir=/bin \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ bindir=${D}/bin \
+ install || die
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+
+ #conflicts with textutils. seems that they install the same
+ #.info file between the two of them
+ rm -f ${D}/usr/share/info/coreutils.info
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+