summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-04-11 21:34:25 +0000
committerAron Griffis <agriffis@gentoo.org>2003-04-11 21:34:25 +0000
commit8163da4e447ca68379e9ea137b4b6e8bcde98411 (patch)
tree59dac4618f30543e040da18b0832d7a5f2c30f6a /sys-apps/findutils
parentupdate ccache to stable to help with bug 19155 (diff)
downloadgentoo-2-8163da4e447ca68379e9ea137b4b6e8bcde98411.tar.gz
gentoo-2-8163da4e447ca68379e9ea137b4b6e8bcde98411.tar.bz2
gentoo-2-8163da4e447ca68379e9ea137b4b6e8bcde98411.zip
fix bug 18729 but leave ~-masked
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog8
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.1.7-r41
-rw-r--r--sys-apps/findutils/findutils-4.1.7-r4.ebuild69
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index a97baebff4f5..c0f0c220542f 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/findutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.12 2003/03/20 17:32:17 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.13 2003/04/11 21:34:25 agriffis Exp $
+
+*findutils-4.1.7-r4 (11 Apr 2003)
+
+ 11 Apr 2003; Aron Griffis <agriffis@gentoo.org> findutils-4.1.7-r4.ebuild:
+ Don't install locate/updatedb because they conflict with slocate, which is a
+ better solution. See bug 18729.
*findutils-4.1.7-r3 (19 Mar 2003)
diff --git a/sys-apps/findutils/files/digest-findutils-4.1.7-r4 b/sys-apps/findutils/files/digest-findutils-4.1.7-r4
new file mode 100644
index 000000000000..71e0d8a53382
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.1.7-r4
@@ -0,0 +1 @@
+MD5 582d9b35006065f81f71d681c165fa1e findutils-4.1.7.tar.gz 634058
diff --git a/sys-apps/findutils/findutils-4.1.7-r4.ebuild b/sys-apps/findutils/findutils-4.1.7-r4.ebuild
new file mode 100644
index 000000000000..9e49807a4754
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.1.7-r4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.7-r4.ebuild,v 1.1 2003/04/11 21:34:25 agriffis Exp $
+
+IUSE="nls build afs selinux"
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNU utilities to find files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${P}.tar.gz
+ selinux? mirror://gentoo/${P}-2003011510-selinux-gentoo.patch.bz2"
+
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+
+KEYWORDS="~x86 ~hppa ~arm ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sed-4
+ nls? ( sys-devel/gettext )
+ afs? ( net-fs/openafs )
+ selinux? ( sys-apps/selinux-small )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ use selinux && epatch ${DISTDIR}/${P}-2003011510-selinux-gentoo.patch.bz2
+}
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ if use afs; then
+ export CPPFLAGS=-I/usr/afsws/include
+ export LDFLAGS=-lpam
+ export LIBS=/usr/afsws/lib/pam_afs.so.1
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} || die
+
+ emake libexecdir=/usr/lib/find || die
+}
+
+src_install() {
+ einstall libexecdir=${D}/usr/lib/find || die
+
+ prepallman
+
+ rm -rf ${D}/usr/var
+ if ! use build; then
+ dodoc COPYING NEWS README TODO ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}