summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-10 08:42:37 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-10 08:42:37 +0000
commit2c0399d679a2563c464031fd3385658fc6f95469 (patch)
tree8c0736221c9f674486a90d496e10ef77e02605b1 /sys-apps/gawk
parentFix LICENSE, see readme.txt in zipballs, bug 506850. (diff)
downloadgentoo-2-2c0399d679a2563c464031fd3385658fc6f95469.tar.gz
gentoo-2-2c0399d679a2563c464031fd3385658fc6f95469.tar.bz2
gentoo-2-2c0399d679a2563c464031fd3385658fc6f95469.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog8
-rw-r--r--sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch26
-rw-r--r--sys-apps/gawk/gawk-4.1.1.ebuild75
3 files changed, 108 insertions, 1 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 6e057ed4d08f..c05975d4a17c 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.177 2014/02/18 18:58:12 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.178 2014/04/10 08:42:37 polynomial-c Exp $
+
+*gawk-4.1.1 (10 Apr 2014)
+
+ 10 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> +gawk-4.1.1.ebuild,
+ +files/gawk-4.1.1-sandbox_issue.patch:
+ Version bump.
18 Feb 2014; Christoph Junghans <ottxor@gentoo.org> gawk-3.1.8.ebuild:
added blocker for >=virtual/awk-1
diff --git a/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch b/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch
new file mode 100644
index 000000000000..c64103550ce1
--- /dev/null
+++ b/sys-apps/gawk/files/gawk-4.1.1-sandbox_issue.patch
@@ -0,0 +1,26 @@
+Fix sandbox issue.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- gawk-4.1.1/extension/Makefile.am 2014-02-20 19:42:25.000000000 +0100
++++ gawk-4.1.1/extension/Makefile.am 2014-02-20 19:42:25.000000000 +0100
+@@ -100,7 +100,7 @@
+
+ install-data-hook:
+ for i in $(pkgextension_LTLIBRARIES) ; do \
+- $(RM) $(pkgextensiondir)/$$i ; \
++ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
+ done
+
+ # Keep the uninstall check working:
+--- gawk-4.1.1/extension/Makefile.in 2014-04-08 18:13:03.000000000 +0200
++++ gawk-4.1.1/extension/Makefile.in 2014-04-08 18:13:03.000000000 +0200
+@@ -1231,7 +1231,7 @@
+
+ install-data-hook:
+ for i in $(pkgextension_LTLIBRARIES) ; do \
+- $(RM) $(pkgextensiondir)/$$i ; \
++ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
+ done
+
+ # Keep the uninstall check working:
diff --git a/sys-apps/gawk/gawk-4.1.1.ebuild b/sys-apps/gawk/gawk-4.1.1.ebuild
new file mode 100644
index 000000000000..cb14b63bd530
--- /dev/null
+++ b/sys-apps/gawk/gawk-4.1.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.1.1.ebuild,v 1.1 2014/04/10 08:42:37 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mpfr nls readline"
+
+RDEPEND="mpfr? ( dev-libs/mpfr )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ EPATCH_OPTS="-Z" \
+ epatch "${FILESDIR}"/${PN}-4.1.1-sandbox_issue.patch
+
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in || die
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
+ # disable pointless build time hack that breaks cross-compiling #493362
+ sed -i \
+ -e '/check-recursive all-recursive: check-for-shared-lib-support/d' \
+ extension/Makefile.in || die
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_with mpfr) \
+ $(use_enable nls) \
+ $(use_with readline)
+}
+
+src_install() {
+ rm -rf README_d # automatic dodocs barfs
+ default
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ rm "${ED}"/usr/include/awk/config.h || die
+}
+
+pkg_postinst() {
+ # symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"usr/share/man/man1/gawk.1* "${EROOT}"usr/bin/gawk; do
+ [[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
+ done
+ [[ ! -e ${EROOT}bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}bin/awk"
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}