summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-11 11:49:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-11 11:49:53 +0000
commit9839bba20f84a078760072a0565acd2cf32c371b (patch)
treedc05674222a58ab4a4f91f625eed2cd0dc8509ea /sys-apps/gentoo-systemd-integration
parentamd64/x86 stable (diff)
downloadgentoo-2-9839bba20f84a078760072a0565acd2cf32c371b.tar.gz
gentoo-2-9839bba20f84a078760072a0565acd2cf32c371b.tar.bz2
gentoo-2-9839bba20f84a078760072a0565acd2cf32c371b.zip
Introduce the first release.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/ChangeLog8
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild28
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild7
3 files changed, 39 insertions, 4 deletions
diff --git a/sys-apps/gentoo-systemd-integration/ChangeLog b/sys-apps/gentoo-systemd-integration/ChangeLog
index 37c3b3cbdfab..584554b82fb5 100644
--- a/sys-apps/gentoo-systemd-integration/ChangeLog
+++ b/sys-apps/gentoo-systemd-integration/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gentoo-systemd-integration
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.3 2013/09/11 10:53:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.4 2013/09/11 11:49:53 mgorny Exp $
+
+*gentoo-systemd-integration-1 (11 Sep 2013)
+
+ 11 Sep 2013; Michał Górny <mgorny@gentoo.org>
+ +gentoo-systemd-integration-1.ebuild, gentoo-systemd-integration-9999.ebuild:
+ Introduce the first release.
11 Sep 2013; Michał Górny <mgorny@gentoo.org>
gentoo-systemd-integration-9999.ebuild:
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild
new file mode 100644
index 000000000000..e6803b7eeaa6
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild,v 1.1 2013/09/11 11:49:53 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-206-r4"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index e2a1c815b687..ce2812c6971e 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild,v 1.3 2013/09/11 10:53:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild,v 1.4 2013/09/11 11:49:53 mgorny Exp $
EAPI=5
@@ -21,8 +21,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""
-RDEPEND="!<=sys-apps/systemd-206
- !=sys-apps/systemd-9999"
+RDEPEND=">=sys-apps/systemd-206-r4"
#if LIVE
SRC_URI=
@@ -35,6 +34,8 @@ DEPEND="${DEPEND}
src_configure() {
local myeconfargs=(
"$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
)
autotools-utils_src_configure