summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-11 22:45:09 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-11 22:45:09 +0000
commit82be118713a3f142c3864b3cdf7cc61022ffae3b (patch)
tree54fbe2b691f7a290133dcc6c799991a070e9daf3 /sys-apps/gradm/gradm-1.9.14.ebuild
parentAdd note about not putting S=${WORKDIR}/${P} in ebuilds. (diff)
downloadgentoo-2-82be118713a3f142c3864b3cdf7cc61022ffae3b.tar.gz
gentoo-2-82be118713a3f142c3864b3cdf7cc61022ffae3b.tar.bz2
gentoo-2-82be118713a3f142c3864b3cdf7cc61022ffae3b.zip
Version bump, and fix the conf.d and init.d scripts to close bug #42750.
Diffstat (limited to 'sys-apps/gradm/gradm-1.9.14.ebuild')
-rw-r--r--sys-apps/gradm/gradm-1.9.14.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/gradm/gradm-1.9.14.ebuild b/sys-apps/gradm/gradm-1.9.14.ebuild
new file mode 100644
index 000000000000..886d808dd9f8
--- /dev/null
+++ b/sys-apps/gradm/gradm-1.9.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-1.9.14.ebuild,v 1.1 2004/03/11 22:45:07 eradicator Exp $
+
+inherit gcc flag-o-matic
+
+DESCRIPTION="Administrative interface for grsecurity ${PV} access control lists"
+SRC_URI="http://www.grsecurity.net/${P}.tar.gz"
+HOMEPAGE="http://www.grsecurity.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa"
+SLOT="0"
+
+IUSE=""
+DEPEND="virtual/glibc
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/chpax"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gradm_parse.c-1.9.x.patch
+
+ # (Jan 2 2004) - <solar@gentoo>
+ # static linking required for proper operation of gradm
+ # however ssp is known to break static linking when it's enabled
+ # in >=gcc-3.3.1 && <=gcc-3.3.2-r5 . So we strip ssp if needed.
+ gmicro=$(gcc-micro-version)
+ if [ "$(gcc-version)" == "3.3" -a -n "${gmicro}" -a ${gmicro} -le 2 ]; then
+ # extract out gentoo revision
+ gentoo_gcc_r=$($(gcc-getCC) -v 2>&1 | tail -n 1 | awk '{print $7}')
+ gentoo_gcc_r=${gentoo_gcc_r/,/}
+ gentoo_gcc_r=${gentoo_gcc_r/-/ }
+ gentoo_gcc_r=${gentoo_gcc_r:7}
+ [ -n "${gentoo_gcc_r}" -a ${gentoo_gcc_r} -le 5 ] && \
+ filter-flags -fstack-protector -fstack-protector-all
+ fi
+
+ sed -i -e "s|-O2|${CFLAGS}|" Makefile
+}
+
+src_compile() {
+ emake CC="$(gcc-getCC)" || die "compile problem"
+}
+
+src_install() {
+ doman gradm.8
+ dodoc acl
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/grsecurity.rc grsecurity
+ insinto /etc/conf.d
+ doins ${FILESDIR}/grsecurity
+ into /
+ dosbin gradm
+ fperms 700 /sbin/gradm
+}