summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-22 04:50:07 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-22 04:50:07 +0000
commit10f4bead48cb1904978c646faddc9db6d2429a99 (patch)
tree597b11dbc1ee772505f8055e5f859ca697b54278 /sys-apps/grub
parentfixum (diff)
downloadgentoo-2-10f4bead48cb1904978c646faddc9db6d2429a99.tar.gz
gentoo-2-10f4bead48cb1904978c646faddc9db6d2429a99.tar.bz2
gentoo-2-10f4bead48cb1904978c646faddc9db6d2429a99.zip
fixums, now installs stuff to /boot/grub, and in rc6 we'll configure GRUB
to look in (hd0,0)/grub (rather than (hd0,0)/boot/grub) if necessary.
Diffstat (limited to 'sys-apps/grub')
-rw-r--r--sys-apps/grub/grub-0.5.96.1-r4.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/sys-apps/grub/grub-0.5.96.1-r4.ebuild b/sys-apps/grub/grub-0.5.96.1-r4.ebuild
index 5eddabc69291..2c8cc873acd4 100644
--- a/sys-apps/grub/grub-0.5.96.1-r4.ebuild
+++ b/sys-apps/grub/grub-0.5.96.1-r4.ebuild
@@ -3,14 +3,12 @@
# Author Daniel Robbins <drobbins@gentoo.org>
# /home/cvsroot/gentoo-x86/sys-apps/grub/grub-0.5.96.1-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
-SRC_URI="ftp://alpha.gnu.org/gnu/grub/${A}"
+SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2-r2"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
src_unpack() {
unpack ${A}
@@ -19,22 +17,18 @@ src_unpack() {
}
src_compile() {
-
- try ./configure --prefix=/usr sbindir=/sbin \
- --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
-
- try make ${MAKEOPTS} -e CPPFLAGS="-Wall -Wmissing-prototypes -Wunused -Wshadow -malign-jumps=1 -malign-loops=1 -malign-functions=1 -Wundef"
+ ./configure --prefix=/usr sbindir=/sbin --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST} || die
+ emake -e CPPFLAGS="-Wall -Wmissing-prototypes -Wunused -Wshadow -malign-jumps=1 -malign-loops=1 -malign-functions=1 -Wundef" || die
}
src_install() {
-
try make prefix=${D}/usr sbindir=${D}/sbin mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
if [ -z "`use bootcd`" ]
then
- dodir /boot/boot/grub
+ dodir /boot/grub
cd ${D}/usr/share/grub/i386-pc
- cp stage1 stage2 *stage1_5 ${D}/boot/boot/grub
+ cp stage1 stage2 *stage1_5 ${D}/boot/grub
cd ${S}
dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO