summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-23 20:43:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-23 20:43:00 +0000
commit7237de3a8534dfd87af583a979ccc3d1a09e21b9 (patch)
tree2b6c8625f1398a9113f8841a3ca54036521c1dd7 /sys-apps/hal
parentStable on alpha, bug #232054 (diff)
downloadgentoo-2-7237de3a8534dfd87af583a979ccc3d1a09e21b9.tar.gz
gentoo-2-7237de3a8534dfd87af583a979ccc3d1a09e21b9.tar.bz2
gentoo-2-7237de3a8534dfd87af583a979ccc3d1a09e21b9.zip
add back die statements to hopefully prevent successful installations when files failed to copy
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/hal-0.5.11-r1.ebuild15
-rw-r--r--sys-apps/hal/hal-0.5.11-r2.ebuild15
-rw-r--r--sys-apps/hal/hal-0.5.11-r3.ebuild15
-rw-r--r--sys-apps/hal/hal-0.5.11-r4.ebuild15
5 files changed, 38 insertions, 29 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 9f0179ca7ab1..4a978d1a966c 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.256 2008/12/19 17:37:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.257 2008/12/23 20:43:00 cardoe Exp $
+
+ 23 Dec 2008; Doug Goldstein <cardoe@gentoo.org> hal-0.5.11-r1.ebuild,
+ hal-0.5.11-r2.ebuild, hal-0.5.11-r3.ebuild, hal-0.5.11-r4.ebuild:
+ add back die statements to hopefully prevent successful installations when
+ files failed to copy
19 Dec 2008; Peter Volkov <pva@gentoo.org> hal-0.5.7.1-r5.ebuild,
hal-0.5.9-r1.ebuild, hal-0.5.9.1-r1.ebuild, hal-0.5.9.1-r2.ebuild,
diff --git a/sys-apps/hal/hal-0.5.11-r1.ebuild b/sys-apps/hal/hal-0.5.11-r1.ebuild
index f4894325f5a1..44188364eb25 100644
--- a/sys-apps/hal/hal-0.5.11-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.12 2008/12/22 21:44:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild,v 1.13 2008/12/23 20:43:00 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -207,22 +207,23 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
# hal umount for unclean unmounts
exeinto /lib/udev/
- newexe "${FILESDIR}/hal-unmount.dev" hal_unmount
+ newexe "${FILESDIR}/hal-unmount.dev" hal_unmount || die "udev helper failed"
# initscript
- newinitd "${FILESDIR}/0.5.10-hald.rc" hald
+ newinitd "${FILESDIR}/0.5.10-hald.rc" hald || die "init script failed"
# configuration
- cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/"
+ cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/" || \
+ die "failed to copy hald.conf"
if use debug; then
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
- -i "${WORKDIR}/0.5.10-hald.conf"
+ -i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
newconfd "${WORKDIR}/0.5.10-hald.conf" hald
diff --git a/sys-apps/hal/hal-0.5.11-r2.ebuild b/sys-apps/hal/hal-0.5.11-r2.ebuild
index 5e104386c1ee..1b50a7c8a87c 100644
--- a/sys-apps/hal/hal-0.5.11-r2.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r2.ebuild,v 1.5 2008/12/19 17:37:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r2.ebuild,v 1.6 2008/12/23 20:43:00 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -207,22 +207,23 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
# hal umount for unclean unmounts
exeinto /lib/udev/
- newexe "${FILESDIR}/hal-unmount.dev" hal_unmount
+ newexe "${FILESDIR}/hal-unmount.dev" hal_unmount || die "udev helper failed"
# initscript
- newinitd "${FILESDIR}/0.5.10-hald.rc" hald
+ newinitd "${FILESDIR}/0.5.10-hald.rc" hald || die "init script failed"
# configuration
- cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/"
+ cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/" || \
+ die "failed to copy hald.conf"
if use debug; then
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
- -i "${WORKDIR}/0.5.10-hald.conf"
+ -i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
newconfd "${WORKDIR}/0.5.10-hald.conf" hald
diff --git a/sys-apps/hal/hal-0.5.11-r3.ebuild b/sys-apps/hal/hal-0.5.11-r3.ebuild
index f353f19d4c5c..b1fe12fa3d57 100644
--- a/sys-apps/hal/hal-0.5.11-r3.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r3.ebuild,v 1.3 2008/12/19 17:37:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r3.ebuild,v 1.4 2008/12/23 20:43:00 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -207,22 +207,23 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
# hal umount for unclean unmounts
exeinto /lib/udev/
- newexe "${FILESDIR}/hal-unmount.dev" hal_unmount
+ newexe "${FILESDIR}/hal-unmount.dev" hal_unmount || die "udev helper failed"
# initscript
- newinitd "${FILESDIR}/0.5.10-hald.rc" hald
+ newinitd "${FILESDIR}/0.5.10-hald.rc" hald || die "init script failed"
# configuration
- cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/"
+ cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/" || \
+ die "failed to copy hald.conf"
if use debug; then
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
- -i "${WORKDIR}/0.5.10-hald.conf"
+ -i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
newconfd "${WORKDIR}/0.5.10-hald.conf" hald
diff --git a/sys-apps/hal/hal-0.5.11-r4.ebuild b/sys-apps/hal/hal-0.5.11-r4.ebuild
index 958e2cf3673f..6ea0d7693041 100644
--- a/sys-apps/hal/hal-0.5.11-r4.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.3 2008/12/19 17:37:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r4.ebuild,v 1.4 2008/12/23 20:43:00 cardoe Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -209,22 +209,23 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die "docs failed"
# hal umount for unclean unmounts
exeinto /lib/udev/
- newexe "${FILESDIR}/hal-unmount.dev" hal_unmount
+ newexe "${FILESDIR}/hal-unmount.dev" hal_unmount || die "udev helper failed"
# initscript
- newinitd "${FILESDIR}/0.5.10-hald.rc" hald
+ newinitd "${FILESDIR}/0.5.10-hald.rc" hald || die "init script failed"
# configuration
- cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/"
+ cp "${FILESDIR}/0.5.10-hald.conf" "${WORKDIR}/" || \
+ die "failed to copy hald.conf"
if use debug; then
sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
- -i "${WORKDIR}/0.5.10-hald.conf"
+ -i "${WORKDIR}/0.5.10-hald.conf" || die "failed to change verbose"
fi
newconfd "${WORKDIR}/0.5.10-hald.conf" hald