summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-03 11:35:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-03 11:35:14 +0000
commit7af5f6d8bbb21089bc2c8830f438b9a833e9e57b (patch)
tree895baf3dcc74634c5264805cc67b91a12233b02d /sys-apps/hwids
parentRename automake-history info file as well, to avoid conflicting with 1.12. (diff)
downloadgentoo-2-7af5f6d8bbb21089bc2c8830f438b9a833e9e57b.tar.gz
gentoo-2-7af5f6d8bbb21089bc2c8830f438b9a833e9e57b.tar.bz2
gentoo-2-7af5f6d8bbb21089bc2c8830f438b9a833e9e57b.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/ChangeLog9
-rw-r--r--sys-apps/hwids/hwids-20130102.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 452db25b7622..6249b5da93fe 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.61 2012/12/31 18:07:13 ryao Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.62 2013/01/03 11:35:14 flameeyes Exp $
+
+*hwids-20130102 (03 Jan 2013)
+
+ 03 Jan 2013; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20130102.ebuild:
+ Version bump.
31 Dec 2012; Richard Yao <ryao@gentoo.org> hwids-20121227.ebuild:
Keyword ~x64-freebsd
diff --git a/sys-apps/hwids/hwids-20130102.ebuild b/sys-apps/hwids/hwids-20130102.ebuild
new file mode 100644
index 000000000000..853ff720dab0
--- /dev/null
+++ b/sys-apps/hwids/hwids-20130102.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130102.ebuild,v 1.1 2013/01/03 11:35:14 flameeyes Exp $
+
+EAPI=5
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux"
+IUSE="+udev"
+
+DEPEND="udev? ( dev-lang/perl !=sys-fs/udev-196 )"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S=${WORKDIR}/hwids-${P}
+
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ # until udev introduces a way to compile the database at a given
+ # location, rather than just /, we can't do much on offset root.
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+
+ if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
+ udevadm hwdb --update
+ fi
+}