summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2006-12-06 14:51:47 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2006-12-06 14:51:47 +0000
commit1199eb543220fe5c0bc9535815fca6662f3f127a (patch)
treed5424be5fc6adafcf577c864096626bff7fdc42d /sys-apps/inputd/inputd-0.0.6.ebuild
parentStable on Alpha. (diff)
downloadgentoo-2-1199eb543220fe5c0bc9535815fca6662f3f127a.tar.gz
gentoo-2-1199eb543220fe5c0bc9535815fca6662f3f127a.tar.bz2
gentoo-2-1199eb543220fe5c0bc9535815fca6662f3f127a.zip
Version bump. Fixes lots of bugs. Remove old ebuilds.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-apps/inputd/inputd-0.0.6.ebuild')
-rw-r--r--sys-apps/inputd/inputd-0.0.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/inputd/inputd-0.0.6.ebuild b/sys-apps/inputd/inputd-0.0.6.ebuild
new file mode 100644
index 000000000000..6100a7192a42
--- /dev/null
+++ b/sys-apps/inputd/inputd-0.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/inputd-0.0.6.ebuild,v 1.1 2006/12/06 14:51:47 hansmi Exp $
+
+inherit eutils
+
+DESCRIPTION="inputd is a user-space daemon to emulate key presses trough other
+key combinations"
+HOMEPAGE="http://hansmi.ch/software/inputd"
+SRC_URI="http://hansmi.ch/download/inputd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.8
+ >=sys-kernel/linux-headers-2.6.16"
+RDEPEND="sys-fs/udev"
+
+src_install() {
+ emake DESTDIR=${D} install || die 'installation failed.'
+
+ newinitd ${FILESDIR}/inputd.init inputd
+ dodoc README doc/FAQ NEWS
+
+ insinto /etc
+ doins doc/inputd.conf
+}
+