summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-03 00:46:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-03 00:46:12 +0000
commitb86953a0fbb4224b5e209a0ac1b6a174370582d9 (patch)
treeb28671b5321d506876fa365891dfac1eb1eab4b3 /sys-apps/ipmitool/ipmitool-1.8.2.ebuild
parentRevision bump with upstream patches. (diff)
downloadgentoo-2-b86953a0fbb4224b5e209a0ac1b6a174370582d9.tar.gz
gentoo-2-b86953a0fbb4224b5e209a0ac1b6a174370582d9.tar.bz2
gentoo-2-b86953a0fbb4224b5e209a0ac1b6a174370582d9.zip
Version bump, bug #101126.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/ipmitool/ipmitool-1.8.2.ebuild')
-rw-r--r--sys-apps/ipmitool/ipmitool-1.8.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/ipmitool/ipmitool-1.8.2.ebuild b/sys-apps/ipmitool/ipmitool-1.8.2.ebuild
new file mode 100644
index 000000000000..7cab6cd681b1
--- /dev/null
+++ b/sys-apps/ipmitool/ipmitool-1.8.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/ipmitool-1.8.2.ebuild,v 1.1 2005/08/03 00:46:12 robbat2 Exp $
+
+DESCRIPTION="Utility for controlling IPMI enabled devices."
+HOMEPAGE="http://ipmitool.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="virtual/libc
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_compile() {
+ econf \
+ --enable-ipmievd --enable-ipmishell \
+ --enable-intf-lan --enable-intf-lanplus \
+ --enable-intf-open --enable-intf-imb \
+ --with-kerneldir=yes --bindir=/usr/sbin \
+ || die "econf failed"
+ # Fix linux/ipmi.h to compile properly. This is a hack since it doesn't
+ # include the below file to define some things.
+ echo "#include <asm/byteorder.h>" >>config.h
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install || die "emake install failed"
+ rm ${D}/usr/share/${PN}/bmclanconf
+ mv ${D}/usr/share/${PN}/ipmi.init* ${D}/usr/share/doc/${PF}/
+ mv ${D}/usr/share/${PN} ${D}/usr/share/doc/${PF}/web
+ into /usr
+ dosbin contrib/bmclanconf
+}
+
+requestinitd() {
+ einfo "Could somebody please write an init.d script for ipmievd, and submit it?"
+}
+
+pkg_preinst() {
+ requestinitd
+}
+
+pkg_postinst() {
+ requestinitd
+}