summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-01 08:15:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-01 08:15:19 +0000
commitc171cb5a69f97ccba80fff6c60cd3bd43fa423e3 (patch)
tree46ced214405d943487741d19b726ecffc9a56ac1 /sys-apps/ipmitool
parentMissed two deps. (diff)
downloadgentoo-2-c171cb5a69f97ccba80fff6c60cd3bd43fa423e3.tar.gz
gentoo-2-c171cb5a69f97ccba80fff6c60cd3bd43fa423e3.tar.bz2
gentoo-2-c171cb5a69f97ccba80fff6c60cd3bd43fa423e3.zip
Initial commit, based on bug #67263, submitted by Michael Locher <xray@trash.net>.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-apps/ipmitool')
-rw-r--r--sys-apps/ipmitool/ipmitool-1.6.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/ipmitool/ipmitool-1.6.0.ebuild b/sys-apps/ipmitool/ipmitool-1.6.0.ebuild
new file mode 100644
index 000000000000..9300c4dc5c43
--- /dev/null
+++ b/sys-apps/ipmitool/ipmitool-1.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipmitool/ipmitool-1.6.0.ebuild,v 1.1 2005/03/01 08:15:19 robbat2 Exp $
+
+DESCRIPTION="Utility for controlling IPMI enabled devices."
+HOMEPAGE="http://${PN}.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="BSD"
+
+RDEPEND="virtual/libc
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_compile() {
+ econf \
+ --enable-ipmievd --enable-ipmishell \
+ --enable-intf-lan --enable-intf-lanplus \
+ --enable-intf-open --enable-intf-imb \
+ --with-kerneldir=yes --bindir=/usr/sbin \
+ || die "econf failed"
+ # Fix linux/ipmi.h to compile properly. This is a hack since it doesn't
+ # include the below file to define some things.
+ echo "#include <asm/byteorder.h>" >>config.h
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" PACKAGE="${PF}" install || die "emake install failed"
+ rm ${D}/usr/share/${PN}/{bmclanconf,ipmi.init}
+ into /usr
+ dosbin contrib/bmclanconf
+}
+
+requestinitd() {
+ einfo "Could somebody please write an init.d script for ipmievd, and submit it?"
+}
+
+pkg_preinst() {
+ requestinitd
+}
+
+pkg_postinst() {
+ requestinitd
+}