summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-11-08 16:32:15 +0000
committerSven Vermeulen <swift@gentoo.org>2014-11-08 16:32:15 +0000
commit77160368e7aff8c949ba7c7370fd8e2fa3278f56 (patch)
treeee1a66829a341d2545a0f99e0d810119263ce478 /sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild
parentRemove Perl 5.16 as provider (diff)
downloadgentoo-2-77160368e7aff8c949ba7c7370fd8e2fa3278f56.tar.gz
gentoo-2-77160368e7aff8c949ba7c7370fd8e2fa3278f56.tar.bz2
gentoo-2-77160368e7aff8c949ba7c7370fd8e2fa3278f56.zip
Fix bug #525724 - Add USE=selinux dependency to selinux-irqbalance
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild')
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild b/sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..a9bb94b38a59
--- /dev/null
+++ b/sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/irqbalance/irqbalance-1.0.7-r1.ebuild,v 1.1 2014/11/08 16:32:15 swift Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="dev-libs/glib:2
+ caps? ( sys-libs/libcap-ng )
+ numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-irqbalance )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~PCI_MSI"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with caps libcap-ng)
+ $(use_enable numa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
+ newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+ systemd_dounit "${FILESDIR}"/irqbalance.service
+}