summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-06 18:13:11 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-06 18:13:11 +0000
commit48b38a04d1db956c023830aa1ca20ad5782ad94d (patch)
tree1c19ed7787ee89d0b488cec45d5edc7218f82a7d /sys-apps/kexec-tools/files
parentStable on sparc wrt #169640 (diff)
downloadgentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.tar.gz
gentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.tar.bz2
gentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.zip
Add ebuild for git tree.
(Portage version: 2.1.2-r14)
Diffstat (limited to 'sys-apps/kexec-tools/files')
-rw-r--r--sys-apps/kexec-tools/files/digest-kexec-tools-99990
-rw-r--r--sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch14
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/files/digest-kexec-tools-9999 b/sys-apps/kexec-tools/files/digest-kexec-tools-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/kexec-tools/files/digest-kexec-tools-9999
diff --git a/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch b/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
new file mode 100644
index 000000000000..c982a3579509
--- /dev/null
+++ b/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
@@ -0,0 +1,14 @@
+this should really be rewritten to invoke the compiler driver (gcc) rather than
+the linker (ld) ...
+
+--- purgatory/Makefile
++++ purgatory/Makefile
+@@ -59,7 +59,7 @@
+
+ $(PURGATORY): $(PURGATORY_OBJS) $(UTIL_LIB)
+ $(MKDIR) -p $(@D)
+- $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
++ $(LD) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
+
+ echo::
+ @echo "PURGATORY_C_SRCS $(PURGATORY_C_SRCS)"