summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-18 10:23:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-18 10:23:37 +0000
commit867e514ff7d6f2adb9c22a7c6862185624c4710c (patch)
treefcbd4693494a678f999e207fe9d537d9d2a9a386 /sys-apps/kmod/kmod-9999.ebuild
parentRemove old (diff)
downloadgentoo-2-867e514ff7d6f2adb9c22a7c6862185624c4710c.tar.gz
gentoo-2-867e514ff7d6f2adb9c22a7c6862185624c4710c.tar.bz2
gentoo-2-867e514ff7d6f2adb9c22a7c6862185624c4710c.zip
Moving binaries to where they are with module-init-tools one last time wrt #447580 by "consus"
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/kmod/kmod-9999.ebuild')
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 51ea396ab4a1..8d2dd67017e5 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.42 2012/12/05 17:13:29 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.43 2012/12/18 10:23:37 ssuominen Exp $
EAPI=4
@@ -54,7 +54,7 @@ src_prepare()
src_configure()
{
econf \
- --bindir=/bin \
+ --bindir=/sbin \
--with-rootlibdir=/$(get_libdir) \
$(use_enable static-libs static) \
$(use_enable tools) \
@@ -72,12 +72,9 @@ src_install()
if use tools; then
local cmd
for cmd in depmod insmod lsmod modinfo modprobe rmmod; do
- dosym kmod /bin/${cmd}
+ dosym kmod /sbin/${cmd}
done
- # Compatibility symlink(s):
- # These are both hardcoded in the Linux kernel source tree wrt #426698
- dosym /bin/kmod /sbin/depmod
- dosym /bin/kmod /sbin/modprobe
+ dosym /sbin/kmod /bin/lsmod
fi
cat <<-EOF > "${T}"/usb-load-ehci-first.conf