summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-06-14 03:55:21 +0000
committerMatt Turner <mattst88@gentoo.org>2011-06-14 03:55:21 +0000
commitd31554388d0afccdaa7ec976221c53314a49f966 (patch)
treea8fcdfab31977c0ee23366447acf23afbeb66092 /sys-apps/lcdutils
parentStable for HPPA (bug #370715). (diff)
downloadgentoo-2-d31554388d0afccdaa7ec976221c53314a49f966.tar.gz
gentoo-2-d31554388d0afccdaa7ec976221c53314a49f966.tar.bz2
gentoo-2-d31554388d0afccdaa7ec976221c53314a49f966.zip
Fix QA issues and bug 298023
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/lcdutils')
-rw-r--r--sys-apps/lcdutils/ChangeLog8
-rw-r--r--sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch50
-rw-r--r--sys-apps/lcdutils/lcdutils-0.2.ebuild21
3 files changed, 63 insertions, 16 deletions
diff --git a/sys-apps/lcdutils/ChangeLog b/sys-apps/lcdutils/ChangeLog
index 82dc9564376b..0892272c2548 100644
--- a/sys-apps/lcdutils/ChangeLog
+++ b/sys-apps/lcdutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/lcdutils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdutils/ChangeLog,v 1.6 2010/10/08 02:07:15 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdutils/ChangeLog,v 1.7 2011/06/14 03:55:20 mattst88 Exp $
+
+ 14 Jun 2011; Matt Turner <mattst88@gentoo.org> lcdutils-0.2.ebuild,
+ +files/include-stdlib.h-for-exit.patch:
+ Fix QA issues and bug 298023
08 Oct 2010; Mart Raudsepp <leio@gentoo.org> lcdutils-0.2.ebuild:
Drop to ~mips
diff --git a/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch b/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch
new file mode 100644
index 000000000000..81870496a529
--- /dev/null
+++ b/sys-apps/lcdutils/files/include-stdlib.h-for-exit.patch
@@ -0,0 +1,50 @@
+From 304013f4c81a13fa2aa3a06628e6a1c57248563c Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 13 Jun 2011 23:42:44 -0400
+Subject: [PATCH] include stdlib.h for exit
+
+---
+ buttond.c | 1 +
+ liblcd.c | 1 +
+ putlcd.c | 1 +
+ 3 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/buttond.c b/buttond.c
+index e99b0dd..40a85ae 100644
+--- a/buttond.c
++++ b/buttond.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
+ #include <unistd.h>
+diff --git a/liblcd.c b/liblcd.c
+index e8fcacf..39bceea 100644
+--- a/liblcd.c
++++ b/liblcd.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/putlcd.c b/putlcd.c
+index c193712..18dc0af 100644
+--- a/putlcd.c
++++ b/putlcd.c
+@@ -16,6 +16,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include "liblcd.h"
+--
+1.7.3.4
+
diff --git a/sys-apps/lcdutils/lcdutils-0.2.ebuild b/sys-apps/lcdutils/lcdutils-0.2.ebuild
index 18ed0a1ead22..2d9f6e25ac8d 100644
--- a/sys-apps/lcdutils/lcdutils-0.2.ebuild
+++ b/sys-apps/lcdutils/lcdutils-0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdutils/lcdutils-0.2.ebuild,v 1.8 2010/10/08 02:07:14 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lcdutils/lcdutils-0.2.ebuild,v 1.9 2011/06/14 03:55:20 mattst88 Exp $
+
+inherit eutils
DESCRIPTION="Cobalt RaQ/Qube LCD Writing and Button reading utilities"
HOMEPAGE="http://people.debian.org/~pm/mips-cobalt/"
@@ -12,22 +14,13 @@ KEYWORDS="-* ~mips ~x86"
IUSE=""
DEPEND=""
-
-pkg_setup() {
- # This package is aimed primarily at Cobalt Microserver systems. Mips originally, but it
- # is reported to work on x86-based systems as well.
- if [ "${PROFILE_ARCH}" != "cobalt" ]; then
- echo ""
- ewarn "This package is only for Cobalt Microserver systems. Its use on other types of"
- ewarn "hardware is untested."
- echo ""
- fi
-}
+RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
sed -i -e "s:CFLAGS=-O2 -Wall:CFLAGS=${CFLAGS}:g" Makefile
+ epatch "${FILESDIR}"/include-stdlib.h-for-exit.patch
}
src_compile() {
@@ -37,5 +30,5 @@ src_compile() {
src_install() {
dobin buttond putlcd || die "dobin failed"
- dodoc Changelog
+ dodoc ChangeLog || die "dodoc failed"
}