summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/man
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/man-1.5.1h-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/man/man-1.5.1h-r2.ebuild b/sys-apps/man/man-1.5.1h-r2.ebuild
new file mode 100644
index 000000000000..316c535e3ab3
--- /dev/null
+++ b/sys-apps/man/man-1.5.1h-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5.1h-r2.ebuild,v 1.1 2001/02/07 15:55:15 achim Exp $
+
+P=man-1.5h1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard commands to read man pages"
+SRC_URI="ftp://ftp.win.tue.nl/pub/linux-local/utils/man/${A}"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc
+ sys-apps/groff"
+
+src_unpacks() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's!/bin:/usr/bin:/usr/ucb:/usr/local/bin:$PATH!/bin /usr/bin /usr/ucb /usr/local/bin $PATH!' configure.orig > configure
+}
+
+src_compile() {
+
+ try ./configure +sgid +fsstnd +lang all
+ for FOOF in src man2html
+ do
+ try pmake ${FOOF}/Makefile MANCONFIG=/usr/share/misc/man.conf
+ cd ${S}/${FOOF}
+ cp Makefile Makefile.orig
+ sed -e "s/gcc -O/gcc ${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}
+ done
+ try make
+
+}
+
+
+src_install() {
+
+ cd src
+
+ exeopts -s -m 2555 -o root -g man
+ exeinto /usr/bin
+ doexe man
+
+ dobin apropos whatis
+ dosbin makewhatis
+
+ insinto /usr/share/misc
+
+ doins ${FILESDIR}/man.conf
+
+ cd ${S}/man2html
+ dobin man2html
+ doman man2html.1
+
+ cd ${S}/man
+ cp Makefile Makefile.orig
+ echo "BINROOTDIR=${D}" > Makefile
+ cat Makefile.orig >> Makefile
+ try make installsubdirs mandir=${D}/usr/share/man
+
+ cd ${S}
+ dodoc COPYING LSM README* TODO
+
+}
+
+