summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-30 02:02:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-30 02:02:12 +0000
commitb9d9dc602fcdb7d8595cf3c26f225a4dfbd4bf0d (patch)
tree61519b71c1b777b09a138b83f54c1386b258f607 /sys-apps/man
parentPatchset 0.1.8. Add 9925_all_6.8.2-fix-mtrr-endless-loop.patch: (#fd.o 2750) ... (diff)
downloadgentoo-2-b9d9dc602fcdb7d8595cf3c26f225a4dfbd4bf0d.tar.gz
gentoo-2-b9d9dc602fcdb7d8595cf3c26f225a4dfbd4bf0d.tar.bz2
gentoo-2-b9d9dc602fcdb7d8595cf3c26f225a4dfbd4bf0d.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog9
-rw-r--r--sys-apps/man/files/digest-man-1.61
-rw-r--r--sys-apps/man/man-1.6.ebuild92
3 files changed, 100 insertions, 2 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 08b6b2b3d21e..492b6837dc0b 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.66 2005/03/04 23:31:53 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.67 2005/06/30 02:02:12 vapier Exp $
+
+*man-1.6 (30 Jun 2005)
+
+ 30 Jun 2005; Mike Frysinger <vapier@gentoo.org> +man-1.6.ebuild:
+ Version bump.
04 Mar 2005; Ciaran McCreesh <ciaranm@gentoo.org> man-1.5p.ebuild:
Move sys-apps/cronbase -> sys-process/cronbase
diff --git a/sys-apps/man/files/digest-man-1.6 b/sys-apps/man/files/digest-man-1.6
new file mode 100644
index 000000000000..67b14c1f05b5
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.6
@@ -0,0 +1 @@
+MD5 c71fed22dd8d28c4bb93905faf95c13e man-1.6.tar.gz 234440
diff --git a/sys-apps/man/man-1.6.ebuild b/sys-apps/man/man-1.6.ebuild
new file mode 100644
index 000000000000..fa4a6f9aa566
--- /dev/null
+++ b/sys-apps/man/man-1.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6.ebuild,v 1.1 2005/06/30 02:02:12 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls"
+
+DEPEND=""
+RDEPEND="sys-process/cronbase
+ >=sys-apps/groff-1.18
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make sure we can build with -j :)
+ epatch ${FILESDIR}/man-1.5p-parallel-make.patch
+
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch ${FILESDIR}/man-1.5p-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch ${FILESDIR}/man-1.5m-groff-1.18.patch
+
+ # makewhatis traverses manpages twice, as default manpath
+ # contains two directories that are symlinked together
+ epatch ${FILESDIR}/man-1.5p-defmanpath-symlinks.patch
+
+ # use non-lazy binds for man. And let portage handling stripping.
+ append-ldflags -Wl,-z,now
+ sed -i \
+ -e "/^LDFLAGS = -s/s:=.*:=${LDFLAGS}:" \
+ src/Makefile.in \
+ || die "failed to edit default LDLFAGS"
+}
+
+src_compile() {
+ tc-export CC BUILD_CC
+
+ local myconf=
+ use nls && myconf="+lang all" || myconf="+lang none"
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:root "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ echo ${files}
+ fi
+}