summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 04:55:11 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 04:55:11 +0000
commit35d718e17be55a283c7572edd1b25e6d8b27a7aa (patch)
treeee30b1bd0a2bd6d3cd21d9de1f609b2f66495882 /sys-apps/memtest86/memtest86-4.0.ebuild
parentSign Manifest (diff)
downloadgentoo-2-35d718e17be55a283c7572edd1b25e6d8b27a7aa.tar.gz
gentoo-2-35d718e17be55a283c7572edd1b25e6d8b27a7aa.tar.bz2
gentoo-2-35d718e17be55a283c7572edd1b25e6d8b27a7aa.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux i686)
Diffstat (limited to 'sys-apps/memtest86/memtest86-4.0.ebuild')
-rw-r--r--sys-apps/memtest86/memtest86-4.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/memtest86/memtest86-4.0.ebuild b/sys-apps/memtest86/memtest86-4.0.ebuild
new file mode 100644
index 000000000000..bb54475a9a03
--- /dev/null
+++ b/sys-apps/memtest86/memtest86-4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-4.0.ebuild,v 1.1 2011/06/15 04:55:11 jer Exp $
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="A stand alone memory test for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="http://www.memtest86.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.0-build.patch #66630
+
+ if use serial ; then
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h \
+ || die "sed failed"
+ fi
+
+ tc-export AS CC LD
+}
+
+src_install() {
+ insinto /boot/memtest86
+ doins memtest.bin || die "doins failed"
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+ einfo " - For grub: (replace '?' with correct numbers for your boot partition)"
+ einfo " > title=Memtest86"
+ einfo " > root (hd?,?)"
+ einfo " > kernel /boot/memtest86/memtest.bin"
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86/memtest.bin"
+ einfo " > label = Memtest86"
+ einfo
+}