summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-05-02 12:54:14 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-05-02 12:54:14 +0000
commitdfc50a0fa5447a74287c29cca2b19dc4bcbbaea1 (patch)
tree7ea97c203f260d4378092cf0635e34595b9e31d0 /sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
parentVersion bump wrt #264498, fix installdir wrt #233141 remove old (diff)
downloadgentoo-2-dfc50a0fa5447a74287c29cca2b19dc4bcbbaea1.tar.gz
gentoo-2-dfc50a0fa5447a74287c29cca2b19dc4bcbbaea1.tar.bz2
gentoo-2-dfc50a0fa5447a74287c29cca2b19dc4bcbbaea1.zip
Revbump to include new location of microcode.dat file, bug #233141
(Portage version: 2.1.6.11/cvs/Linux ia64)
Diffstat (limited to 'sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild')
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
new file mode 100644
index 000000000000..78f5749d55d0
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild,v 1.1 2009/05/02 12:54:14 armin76 Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/microcode-data-20090330"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc-r1 microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}