summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-09-14 16:38:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-09-14 16:38:47 +0000
commit582bbd563248bd02a53d9cd0b884b89f416d8c52 (patch)
tree2888202a85954de7513294208e6ac3c7d7576436 /sys-apps/microcode-ctl
parentadd optional dependencies (diff)
downloadgentoo-2-582bbd563248bd02a53d9cd0b884b89f416d8c52.tar.gz
gentoo-2-582bbd563248bd02a53d9cd0b884b89f416d8c52.tar.bz2
gentoo-2-582bbd563248bd02a53d9cd0b884b89f416d8c52.zip
Version bump re bug #476208
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog10
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild4
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.23.ebuild49
3 files changed, 59 insertions, 4 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 048849989141..18256f8390dc 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.32 2011/01/24 14:16:01 darkside Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.33 2013/09/14 16:38:47 hwoarang Exp $
+
+*microcode-ctl-1.23 (14 Sep 2013)
+
+ 14 Sep 2013; Markos Chandras <hwoarang@gentoo.org> +microcode-ctl-1.23.ebuild,
+ microcode-ctl-1.17-r2.ebuild:
+ Version bump re bug #476208
24 Jan 2011; Jeremy Olexa <darkside@gentoo.org>
microcode-ctl-1.17-r2.ebuild:
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
index 1c99b6fda911..5f3d13cda2e8 100644
--- a/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild,v 1.3 2011/01/24 14:16:01 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.17-r2.ebuild,v 1.4 2013/09/14 16:38:47 hwoarang Exp $
inherit linux-info toolchain-funcs
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.23.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.23.ebuild
new file mode 100644
index 000000000000..0db1f8c114bb
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.23.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.23.ebuild,v 1.1 2013/09/14 16:38:47 hwoarang Exp $
+
+EAPI="5"
+
+inherit linux-info toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="https://fedorahosted.org/microcode_ctl/"
+SRC_URI="https://fedorahosted.org/released/${PN/-/_}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/microcode-data-20090330"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc-r1 microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ # Just a friendly warning
+ if ! linux_config_exists || ! linux_chkconfig_present MICROCODE; then
+ echo
+ ewarn "Your kernel must include microcode update support."
+ ewarn " Processor type and features --->"
+ ewarn " <*> /dev/cpu/microcode - microcode support"
+ echo
+ fi
+ elog "Microcode updates will be lost at every reboot."
+ elog "You can use the init.d script to update at boot time."
+}