summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2007-04-16 23:10:52 +0000
committerNed Ludd <solar@gentoo.org>2007-04-16 23:10:52 +0000
commitf0cd2b06269a1c78691e614707cda2286432f430 (patch)
treea056f1c57d8fa6fa7c782d8cb2248df8cfe77224 /sys-apps/paxctl/paxctl-0.5.ebuild
parentStable on x86, bug #174833. (diff)
downloadgentoo-2-f0cd2b06269a1c78691e614707cda2286432f430.tar.gz
gentoo-2-f0cd2b06269a1c78691e614707cda2286432f430.tar.bz2
gentoo-2-f0cd2b06269a1c78691e614707cda2286432f430.zip
- version bump to deal with the creation of PT_PAX_FLAGS on upx compressed executables. I removed some older ebuilds also.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-apps/paxctl/paxctl-0.5.ebuild')
-rw-r--r--sys-apps/paxctl/paxctl-0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/paxctl/paxctl-0.5.ebuild b/sys-apps/paxctl/paxctl-0.5.ebuild
new file mode 100644
index 000000000000..6cd277069185
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.5.ebuild,v 1.1 2007/04/16 23:10:52 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}