summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-07 10:13:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-07 10:13:18 +0000
commit22c2d864c8b3135a68295bf0a9adc60ad4f4c461 (patch)
tree9172213d74cef33065df3700d2b831b00c1a1855 /sys-apps/pciutils
parentAdded soname to libRmath, closing bug #235830. Changed herd from sci to sci-m... (diff)
downloadgentoo-2-22c2d864c8b3135a68295bf0a9adc60ad4f4c461.tar.gz
gentoo-2-22c2d864c8b3135a68295bf0a9adc60ad4f4c461.tar.bz2
gentoo-2-22c2d864c8b3135a68295bf0a9adc60ad4f4c461.zip
Bug #240292, version bump.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog8
-rw-r--r--sys-apps/pciutils/files/pciutils-3.0.0-locale-happiness.patch26
-rw-r--r--sys-apps/pciutils/pciutils-3.0.2.ebuild64
3 files changed, 97 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 52af91a403b2..0b70a7e43465 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.144 2008/08/25 13:10:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.145 2008/10/07 10:13:18 robbat2 Exp $
+
+*pciutils-3.0.2 (07 Oct 2008)
+
+ 07 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/pciutils-3.0.0-locale-happiness.patch, +pciutils-3.0.2.ebuild:
+ Bug #240292, version bump.
25 Aug 2008; Raúl Porcel <armin76@gentoo.org> pciutils-3.0.0.ebuild:
ia64 stable wrt #235028
diff --git a/sys-apps/pciutils/files/pciutils-3.0.0-locale-happiness.patch b/sys-apps/pciutils/files/pciutils-3.0.0-locale-happiness.patch
new file mode 100644
index 000000000000..5a818b4c089f
--- /dev/null
+++ b/sys-apps/pciutils/files/pciutils-3.0.0-locale-happiness.patch
@@ -0,0 +1,26 @@
+et_EE is a very fun locale. [a-z] does not expand to the full alphabet in that
+crazy place. Force tr to use locale C just to avoid the problem.
+
+diff -Nuar pciutils-3.0.2.orig/lib/configure pciutils-3.0.2/lib/configure
+--- pciutils-3.0.2.orig/lib/configure 2008-09-19 11:04:37.000000000 -0700
++++ pciutils-3.0.2/lib/configure 2008-10-07 02:27:57.043215842 -0700
+@@ -39,7 +39,7 @@
+ HOST=${3:-$cpu-$sys}
+ fi
+ # CAVEAT: tr on Solaris is a bit weird and the extra [] is otherwise harmless.
+-host=`echo $HOST | sed 's/^\([^-]*\)-\([^-]*\)$/\1--\2/' | tr '[A-Z]' '[a-z]'`
++host=`echo $HOST | sed 's/^\([^-]*\)-\([^-]*\)$/\1--\2/' | LANG=C tr '[A-Z]' '[a-z]'`
+ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
+ sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`
+ echo " $host $rel"
+@@ -47,8 +47,8 @@
+ c=config.h
+ m=config.mk
+ echo >$c '#define PCI_CONFIG_H'
+-echo >>$c "#define PCI_ARCH_`echo $cpu | tr '[a-z]' '[A-Z]'`"
+-echo >>$c "#define PCI_OS_`echo $sys | tr '[a-z]' '[A-Z]'`"
++echo >>$c "#define PCI_ARCH_`echo $cpu | LANG=C tr '[a-z]' '[A-Z]'`"
++echo >>$c "#define PCI_OS_`echo $sys | LANG=C tr '[a-z]' '[A-Z]'`"
+ echo >$m 'WITH_LIBS='
+
+ echo_n "Looking for access methods..."
diff --git a/sys-apps/pciutils/pciutils-3.0.2.ebuild b/sys-apps/pciutils/pciutils-3.0.2.ebuild
new file mode 100644
index 000000000000..b5f93751581d
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-3.0.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-3.0.2.ebuild,v 1.1 2008/10/07 10:13:18 robbat2 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.0-build.patch #233314
+ #epatch "${FILESDIR}"/${PN}-3.0.0-resolv.patch #218555 #Merged
+ epatch "${FILESDIR}"/pcimodules-${PN}-3.0.0.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ epatch "${FILESDIR}"/${PN}-3.0.0-locale-happiness.patch
+ sed -i -e "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+uyesno() { use $1 && echo yes || echo no ; }
+pemake() {
+ emake \
+ DNS="yes" \
+ IDSDIR="/usr/share/misc" \
+ MANDIR="/usr/share/man" \
+ PREFIX="/usr" \
+ SHARED="yes" \
+ STRIP="" \
+ ZLIB=$(uyesno zlib) \
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ pemake OPT="${CFLAGS}" all pcimodules || die "emake failed"
+}
+
+src_install() {
+ pemake DESTDIR="${D}" install install-lib || die
+ dosbin pcimodules || die
+ newman pcimodules.man pcimodules.8
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+
+ # Install both forms until HAL has migrated
+ if use zlib ; then
+ local sharedir="${D}/usr/share/misc"
+ elog "Providing a backwards compatibility non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}