summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-27 19:25:27 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-27 19:25:27 +0000
commit6a3757e76227d7e8704be4d451f2f74583f78a5b (patch)
treef9301752963fbdc48f48c4cecdc624f7ada6c967 /sys-apps/pcmcia-cs-tools
parentVersion bumped. Thanks to Jeff Ames <jca@cwru.edu>, closing bug #43911 (Manif... (diff)
downloadgentoo-2-6a3757e76227d7e8704be4d451f2f74583f78a5b.tar.gz
gentoo-2-6a3757e76227d7e8704be4d451f2f74583f78a5b.tar.bz2
gentoo-2-6a3757e76227d7e8704be4d451f2f74583f78a5b.zip
QA - fix use invocation, also repairing version 3.2.4, which contained [ -n `use build` ]. That construct always evaluates to true because it lacks proper quoting... another good reason to switch to the newer use invocation.
Diffstat (limited to 'sys-apps/pcmcia-cs-tools')
-rw-r--r--sys-apps/pcmcia-cs-tools/ChangeLog9
-rw-r--r--sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild8
-rw-r--r--sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild27
3 files changed, 23 insertions, 21 deletions
diff --git a/sys-apps/pcmcia-cs-tools/ChangeLog b/sys-apps/pcmcia-cs-tools/ChangeLog
index 7c3cc62fd7b9..8297545c4d99 100644
--- a/sys-apps/pcmcia-cs-tools/ChangeLog
+++ b/sys-apps/pcmcia-cs-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pcmcia-cs-tools
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/ChangeLog,v 1.7 2004/06/24 22:21:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/ChangeLog,v 1.8 2004/06/27 19:25:27 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ pcmcia-cs-tools-3.2.3.ebuild, pcmcia-cs-tools-3.2.4.ebuild:
+ QA - fix use invocation, also repairing version 3.2.4, which contained
+ [ -n `use build` ]. That construct always evaluates to true because
+ it lacks proper quoting... another good reason to switch to the
+ newer use invocation.
13 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
pcmcia-cs-tools-3.2.3.ebuild, pcmcia-cs-tools-3.2.4.ebuild:
diff --git a/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild b/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild
index 0471cf44e4b3..22e86c1a7d79 100644
--- a/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild
+++ b/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild,v 1.8 2004/06/24 22:21:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.3.ebuild,v 1.9 2004/06/27 19:25:27 agriffis Exp $
MY_P=${P/-tools/}
S=${WORKDIR}/${MY_P}
@@ -69,10 +69,10 @@ src_compile() {
# installed.
sed -e "/^HAS_FORMS/d" config.out > config.out.1
sed -e "/^HAS_FORMS/d" config.mk > config.mk.1
- if [ -z `use gtk` -o -n `use build` ]; then
+ if ! use gtk || use build; then
sed -i -e "/^HAS_GTK/d" config.out.1
sed -i -e "/^HAS_GTK/d" config.mk.1
- if [ -z `use X` -o -n `use build` ]; then
+ if ! use X || use build; then
sed -i -e "/^HAS_XAW/d" config.out.1
sed -i -e "/^HAS_XAW/d" config.mk.1
fi
@@ -109,7 +109,7 @@ src_install () {
# install our own init script
exeinto /etc/init.d
newexe ${FILESDIR}/pcmcia.rc pcmcia
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
# install docs
diff --git a/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild b/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild
index 94b3687129f4..74398aa9b4b2 100644
--- a/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild
+++ b/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild,v 1.6 2004/06/24 22:21:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-tools/pcmcia-cs-tools-3.2.4.ebuild,v 1.7 2004/06/27 19:25:27 agriffis Exp $
MY_P=${P/-tools/}
S=${WORKDIR}/${MY_P}
@@ -70,10 +70,10 @@ src_compile() {
# installed.
sed -e "/^HAS_FORMS/d" config.out > config.out.1
sed -e "/^HAS_FORMS/d" config.mk > config.mk.1
- if [ -z `use gtk` ] || [ -n `use build` ]; then
+ if ! use gtk || use build; then
sed -i -e "/^HAS_GTK/d" config.out.1
sed -i -e "/^HAS_GTK/d" config.mk.1
- if [ -z `use X` ] || [ -n `use build` ]; then
+ if ! use X || use build; then
sed -i -e "/^HAS_XAW/d" config.out.1
sed -i -e "/^HAS_XAW/d" config.mk.1
fi
@@ -83,21 +83,16 @@ src_compile() {
rm -f config.out.1
rm -f config.mk.1
- cd ${S}/cardmgr
- emake all || die "failed compiling"
- cd ${S}/flash
- emake all || die "failed compiling"
+ emake all -C ${S}/cardmgr || die "failed compiling"
+ emake all -C ${S}/flash || die "failed compiling"
}
src_install () {
- cd ${S}/cardmgr
- make PREFIX=${D} install || die "failed installing"
- cd ${S}/flash
- make PREFIX=${D} install || die "failed installing"
- cd ${S}/etc
- make PREFIX=${D} install || die "failed installing"
- cd ${S}/man
- make PREFIX=${D} install-man1-x11 install-man5 install-man8
+ make install PREFIX=${D} -C ${S}/cardmgr || die "failed installing"
+ make install PREFIX=${D} -C ${S}/flash || die "failed installing"
+ make install PREFIX=${D} -C ${S}/etc || die "failed installing"
+ make install-man1-x11 install-man5 install-man8 PREFIX=${D} -C ${S}/man \
+ || die "failed installing"
rm -rf ${D}/etc/rc*.d
@@ -110,7 +105,7 @@ src_install () {
# install our own init script
exeinto /etc/init.d
newexe ${FILESDIR}/pcmcia.rc pcmcia
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
# install docs