summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-02-26 04:42:00 +0000
committerPeter Johanson <latexer@gentoo.org>2003-02-26 04:42:00 +0000
commit2b5a9affc15a20ba4c29961b0e7b2d6fccfbe4b0 (patch)
treec36ef7b562ef2288ba4224891e43cb694c1e7ba3 /sys-apps/pcmcia-cs
parentinitial ebuild #11784 (diff)
downloadgentoo-2-2b5a9affc15a20ba4c29961b0e7b2d6fccfbe4b0.tar.gz
gentoo-2-2b5a9affc15a20ba4c29961b0e7b2d6fccfbe4b0.tar.bz2
gentoo-2-2b5a9affc15a20ba4c29961b0e7b2d6fccfbe4b0.zip
Version bump for orinoco drivers
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog7
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.1-r43
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r4.ebuild164
3 files changed, 173 insertions, 1 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index a4e351e2b468..3d74d6980258 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.31 2003/02/22 17:35:01 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.32 2003/02/26 04:42:00 latexer Exp $
+
+*pcmcia-cs-3.2.3-r4 (25 Feb 2003)
+
+ 25 Feb 2003; Peter Johanson <latexer@gentoo.org> pcmcia-cs-3.2.1-r4 :
+ Version bump to use latest ornico driver (0.13b)
27 Jan 2003; Chad Huneycutt <chadh@gentoo.org> : old ebuilds
Removed old ebuilds. If you really need something, let me know, and I will
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.1-r4 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.1-r4
new file mode 100644
index 000000000000..a7f5d9639ae2
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.1-r4
@@ -0,0 +1,3 @@
+MD5 7e9f01a697d2e3e5164340d79474ea30 pcmcia-cs-3.2.1.tar.gz 1250413
+MD5 f880ed8e941655bd3da5c533668f4349 orinoco-0.13b-patched.diff 24386
+MD5 0ac2c1e31670e5dbce50133f9eacdb95 orinoco-0.13b.tar.gz 64068
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r4.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r4.ebuild
new file mode 100644
index 000000000000..d2ea84320965
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r4.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r4.ebuild,v 1.1 2003/02/26 04:42:00 latexer Exp $
+
+NOCO_VERSION="0.13b"
+
+S=${WORKDIR}/${P}
+OV="orinoco-${NOCO_VERSION}"
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://airsnort.shmoo.com/${OV}-patched.diff
+ http://ozlabs.org/people/dgibson/dldwd/${OV}.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ if [ -z "`use wavelan`" ] ; then
+
+ unpack ${OV}.tar.gz
+ cd ${WORKDIR}/${OV}
+ patch -p1 < ${DISTDIR}/${OV}-patch.diff
+
+ cd ${S}
+ mv ../${OV}/hermes*.{c,h} \
+ ../${OV}/orinoco*.{c,h} \
+ ../${OV}/ieee802_11.h wireless/
+ fi
+
+
+
+ cd ${S}
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+
+ cd ${S}
+ ### As per the SourceForge web site reqs and bug #3400
+ # We'll replace all ide_cs with ide-cs
+ cp etc/config etc/config.orig
+ sed -e 's:ide_cs:ide-cs:g' etc/config.orig > etc/config
+ rm -f etc/config.orig
+
+
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+
+ sed -e "/^HAS_FORMS/d" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.sed
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.sed > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.sed > config.mk
+ rm -f config.out.sed
+ rm -f config.mk.sed
+
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+pkg_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+ einfo ""
+ einfo "Proper kernel config for this package is that PCMCIA/CardBus under General Setup is off and"
+ einfo "Wireless LAN (non-ham radio) is on but no modules or drivers turned on under Network Device Support"
+ einfo "if you have wireless."
+ einfo ""
+ einfo "If you *don't* want to use Orinoco drivers or if they don't work for you, add +wavelan to USE"
+}