summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2002-11-17 20:28:46 +0000
committerHanno Böck <hanno@gentoo.org>2002-11-17 20:28:46 +0000
commita3f46056b06d9d0ed21dd62c389ee5dbe1f26dff (patch)
tree2e7433d1b3300d821250e83283881a351d437832 /sys-apps/pcmcia-cs
parentpcmcia-cs mask for new version (diff)
downloadgentoo-2-a3f46056b06d9d0ed21dd62c389ee5dbe1f26dff.tar.gz
gentoo-2-a3f46056b06d9d0ed21dd62c389ee5dbe1f26dff.tar.bz2
gentoo-2-a3f46056b06d9d0ed21dd62c389ee5dbe1f26dff.zip
new pcmcia-cs and some ebuild cleanup (see changelog)
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog12
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.32
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.3.ebuild123
3 files changed, 136 insertions, 1 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index 96f4b2ddd368..f37591fa219f 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.23 2002/11/11 19:35:55 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.24 2002/11/17 20:28:46 hanno Exp $
+
+*pcmcia-cs-3.2.3 (17 Nov 2002)
+
+ 17 Nov 2002; Hanno Boeck <hanno@gentoo.org> pcmcia-cs-3.2.3.ebuild :
+ New version. Cleaned up ebuild a lot.
+ Changes:
+ - Updated orinoco-driver to 0.13a
+ - Removed use of wavelan-keyword, orinoco-driver should be updated always.
+ - Remove replacement of ide_cs with ide-cs, this is fixed upstream.
+ - Some cleanups to make ebuild more readable and some lintool-fixes.
*pcmcia-cs-3.2.2 (28 Oct 2002)
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.3 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.3
new file mode 100644
index 000000000000..62abe4e41c82
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.3
@@ -0,0 +1,2 @@
+MD5 581749071efdfc8056ed05f0373d5b79 pcmcia-cs-3.2.3.tar.gz 1255022
+MD5 e7dbdef7e17448e51fded6a24dffbfe1 orinoco-0.13a.tar.gz 63089
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.3.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.3.ebuild
new file mode 100644
index 000000000000..4fc1a4787b2f
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.3.ebuild,v 1.1 2002/11/17 20:28:46 hanno Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://ozlabs.org/people/dgibson/dldwd/orinoco-0.13a.tar.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+IUSE="trusted apm pnp nocardbus build"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ unpack orinoco-0.13a.tar.gz
+ mv orinoco-0.13a/hermes*.{c,h} \
+ orinoco-0.13a/orinoco*.{c,h} \
+ orinoco-0.13a/ieee802_11.h \
+ ${P}/wireless/
+
+ cd ${S}
+ cp Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ #man pages will now install into /usr/share/man
+}
+
+src_compile() {
+ local myconf
+ use trusted && myconf="--trust" || myconf="--notrust"
+ use apm && myconf="$myconf --apm" || myconf="$myconf --noapm"
+ use pnp && myconf="$myconf --pnp" || myconf="$myconf --nopnp"
+ use nocardbus && myconf="$myconf --nocardbus" || myconf="$myconf --cardbus"
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+
+ sed -e "/^HAS_FORMS/d" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.sed
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.sed > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.sed > config.mk
+ rm -f config.out.sed
+ rm -f config.mk.sed
+
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are installed, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+pkg_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+ einfo ""
+ einfo "Proper kernel config for this package is that PCMCIA/CardBus under General Setup is off and"
+ einfo "Wireless LAN (non-ham radio) is on but no modules or drivers turned on under Network Device Support"
+ einfo "if you have wireless."
+}