summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-11-01 08:06:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-11-01 08:06:16 +0000
commit3ad2fca1002ecdd38a93230d03062bb0b3c676a0 (patch)
tree62afd8cfdb31eaac26ea3d90157eb5e6f12cd3f5 /sys-apps/pcmciautils
parentFixing live ebuild for #439192 (diff)
downloadgentoo-2-3ad2fca1002ecdd38a93230d03062bb0b3c676a0.tar.gz
gentoo-2-3ad2fca1002ecdd38a93230d03062bb0b3c676a0.tar.bz2
gentoo-2-3ad2fca1002ecdd38a93230d03062bb0b3c676a0.zip
Version bump. Include patch from Debian to remove sys-fs/sysfsutils dependency wrt #377697 by Anthony Basile. Remove now out of date notification from pkg_postinst() wrt #440592 by "poletti.marco"
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pcmciautils')
-rw-r--r--sys-apps/pcmciautils/ChangeLog10
-rw-r--r--sys-apps/pcmciautils/pcmciautils-018_p8.ebuild73
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/pcmciautils/ChangeLog b/sys-apps/pcmciautils/ChangeLog
index 9ad69fd884b7..5f7bdb2c47b7 100644
--- a/sys-apps/pcmciautils/ChangeLog
+++ b/sys-apps/pcmciautils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/pcmciautils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/ChangeLog,v 1.40 2012/10/31 19:24:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/ChangeLog,v 1.41 2012/11/01 08:06:16 ssuominen Exp $
+
+*pcmciautils-018_p8 (01 Nov 2012)
+
+ 01 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +pcmciautils-018_p8.ebuild:
+ Version bump. Include patch from Debian to remove sys-fs/sysfsutils
+ dependency wrt #377697 by Anthony Basile. Remove now out of date notification
+ from pkg_postinst() wrt #440592 by "poletti.marco"
31 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> pcmciautils-017.ebuild:
Use virtual/yacc instead of hardcoding dev-util/yacc wrt #425756 by David
diff --git a/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild b/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
new file mode 100644
index 000000000000..b8cf1a433ce3
--- /dev/null
+++ b/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/pcmciautils-018_p8.ebuild,v 1.1 2012/11/01 08:06:16 ssuominen Exp $
+
+EAPI=4
+inherit flag-o-matic linux-info toolchain-funcs udev
+
+DEB_REV=${PV#*_p}
+MY_PV=${PV%_p*}
+
+DESCRIPTION="PCMCIA userspace utilities for Linux"
+HOMEPAGE="http://packages.qa.debian.org/pcmciautils"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_REV}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
+IUSE="debug staticsocket"
+
+RDEPEND="virtual/modutils"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ CONFIG_CHECK="~PCMCIA"
+ linux-info_pkg_setup
+
+ kernel_is lt 2 6 32 && ewarn "${P} requires at least kernel 2.6.32."
+
+ mypcmciaopts=(
+ STARTUP=$(usex staticsocket true false)
+ exec_prefix=/usr
+ UDEV=true
+ DEBUG=false
+ STATIC=false
+ V=true
+ udevdir="$(udev_get_udevdir)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ AR="$(tc-getAR)"
+ STRIP=true
+ RANLIB="$(tc-getRANLIB)"
+ OPTIMIZATION="${CFLAGS} ${CPPFLAGS}"
+ DESTDIR="${D}"
+ )
+
+ use debug && append-cppflags -DDEBUG
+}
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/no-modprobe-rules.patch \
+ "${WORKDIR}"/debian/patches/remove-libsysfs-dep.patch
+
+ sed -i \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/dir/s:sbin:bin:g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake "${mypcmciaopts[@]}"
+}
+
+src_install() {
+ emake "${mypcmciaopts[@]}" install
+
+ dodoc doc/*.txt
+}