summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-05-26 10:16:17 +0000
committerThilo Bangert <bangert@gentoo.org>2010-05-26 10:16:17 +0000
commit98e048974e4ebff150edc24a860f8d0143bb715b (patch)
treeb3833325dc3555aa29727453c1deeb8f3e4be309 /sys-apps/pcmciautils
parentRename libpng12 to libpng in configure.in for pkg-config wrt #321525 by Diego... (diff)
downloadgentoo-2-98e048974e4ebff150edc24a860f8d0143bb715b.tar.gz
gentoo-2-98e048974e4ebff150edc24a860f8d0143bb715b.tar.bz2
gentoo-2-98e048974e4ebff150edc24a860f8d0143bb715b.zip
version bump (#300810)
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-apps/pcmciautils')
-rw-r--r--sys-apps/pcmciautils/ChangeLog9
-rw-r--r--sys-apps/pcmciautils/pcmciautils-017.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/sys-apps/pcmciautils/ChangeLog b/sys-apps/pcmciautils/ChangeLog
index 08389044b6da..746f94eff85c 100644
--- a/sys-apps/pcmciautils/ChangeLog
+++ b/sys-apps/pcmciautils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcmciautils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/ChangeLog,v 1.36 2009/10/16 19:19:38 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/ChangeLog,v 1.37 2010/05/26 10:16:17 bangert Exp $
+
+*pcmciautils-017 (26 May 2010)
+
+ 26 May 2010; Thilo Bangert <bangert@gentoo.org> +pcmciautils-017.ebuild:
+ version bump (#300810)
*pcmciautils-016 (16 Oct 2009)
diff --git a/sys-apps/pcmciautils/pcmciautils-017.ebuild b/sys-apps/pcmciautils/pcmciautils-017.ebuild
new file mode 100644
index 000000000000..1a18d7803140
--- /dev/null
+++ b/sys-apps/pcmciautils/pcmciautils-017.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmciautils/pcmciautils-017.ebuild,v 1.1 2010/05/26 10:16:17 bangert Exp $
+
+inherit eutils flag-o-matic toolchain-funcs linux-info
+
+DESCRIPTION="PCMCIA userspace utilities for Linux kernel 2.6.13 and beyond"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/pcmcia/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
+IUSE="debug static staticsocket"
+
+RDEPEND=">=sys-fs/sysfsutils-1.3.0
+ >=sys-apps/module-init-tools-3.2_pre4"
+DEPEND="${RDEPEND}
+ dev-util/yacc
+ sys-devel/flex"
+
+CONFIG_CHECK="~PCMCIA"
+ERROR_PCMCIA="${P} requires 16-bit PCMCIA support (CONFIG_PCMCIA)"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ kernel_is lt 2 6 13 && ewarn "${P} requires at least kernel 2.6.13."
+}
+
+use_tf() { use $1 && echo true || echo false ; }
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^DEBUG\>/s:=.*:= false:' \
+ -e '/^UDEV\>/s:=.*:= true:' \
+ -e '/CFLAGS/s:-fomit-frame-pointer::' \
+ -e '/^STATIC\>/s:=.*:= '$(use_tf static)':' \
+ -e '/^STARTUP\>/s:=.*:= '$(use_tf staticsocket)':' \
+ Makefile || die
+ use debug && append-flags -DDEBUG
+}
+
+src_compile() {
+ emake \
+ OPTIMIZATION="${CFLAGS} ${CPPFLAGS}" \
+ V="true" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ STRIP="true" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ ewarn "If you relied on pcmcia-cs to automatically load the appropriate"
+ ewarn "PCMCIA-related modules upon boot, you need to add 'pcmcia' and the"
+ ewarn "PCMCIA socket driver you need for this system (yenta-socket,"
+ ewarn "i82092, i82365, ...) to /etc/modules.autoload.d/kernel-2.6"
+}