summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-05 10:10:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-05 10:10:31 +0000
commit656edacf2d3e35984859db3fe33a94731728583f (patch)
tree267e705c46aaef542a0df76f538350841183cfe9 /sys-apps/qingy
parentEAPI bump (diff)
downloadgentoo-2-656edacf2d3e35984859db3fe33a94731728583f.tar.gz
gentoo-2-656edacf2d3e35984859db3fe33a94731728583f.tar.bz2
gentoo-2-656edacf2d3e35984859db3fe33a94731728583f.zip
Use pkg-config instead of AC_CHECK_LIB to get ncurses libraries wrt #459650 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/qingy')
-rw-r--r--sys-apps/qingy/ChangeLog7
-rw-r--r--sys-apps/qingy/files/qingy-1.0.0-tinfo.patch42
-rw-r--r--sys-apps/qingy/qingy-1.0.0.ebuild90
3 files changed, 93 insertions, 46 deletions
diff --git a/sys-apps/qingy/ChangeLog b/sys-apps/qingy/ChangeLog
index 185d3e841364..0e95b5eac9b7 100644
--- a/sys-apps/qingy/ChangeLog
+++ b/sys-apps/qingy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/qingy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.68 2013/02/02 12:10:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/ChangeLog,v 1.69 2013/03/05 10:10:31 ssuominen Exp $
+
+ 05 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> qingy-1.0.0.ebuild,
+ +files/qingy-1.0.0-tinfo.patch:
+ Use pkg-config instead of AC_CHECK_LIB to get ncurses libraries wrt #459650
+ by Diego Elio Pettenò
02 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup up due #48914
diff --git a/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch b/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
new file mode 100644
index 000000000000..f752996c92f5
--- /dev/null
+++ b/sys-apps/qingy/files/qingy-1.0.0-tinfo.patch
@@ -0,0 +1,42 @@
+Use ncurses.pc to get Libs: instead of using AC_CHECK_LIB because ncurses can be configured
+to have separate termcap library called libtinfo; and we need both -ltinfo and -lncurses for
+linking since symbols are used from both
+
+http://bugs.gentoo.org/459650
+
+--- configure.in
++++ configure.in
+@@ -125,12 +125,7 @@
+ # End compile emacs stuff
+
+ # Check for ncurses
+- HEADERS="curses.h term.h"
+- NCURSESLIB=""
+- AC_CHECK_HEADERS([$HEADERS],,[AC_MSG_ERROR([$HEADERS_ERROR_MESSAGE])],)
+- AC_CHECK_LIB(ncurses, setupterm, [NCURSESLIB="-lncurses"],[AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])] , )
+- AC_CHECK_LIB(ncurses, tputs, [NCURSESLIB="-lncurses"],[AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])] , )
+- AC_SUBST(NCURSESLIB)
++ PKG_CHECK_MODULES(NCURSES, ncurses, [], [AC_MSG_ERROR([$LIBRARIES_ERROR_MESSAGE])])
+ # End check for ncurses
+
+ # Check for PAM support
+--- src/libraries/Makefile.am
++++ src/libraries/Makefile.am
+@@ -4,7 +4,7 @@
+ INCLUDES = -I../.. -I../
+ BUILT_SOURCES = parse_settings.h
+
+-AM_CFLAGS = -DSETTINGS_DIR=\"$(sysconfdir)/qingy\" -DSBINDIR=\"$(sbindir)/\"
++AM_CFLAGS = -DSETTINGS_DIR=\"$(sysconfdir)/qingy\" -DSBINDIR=\"$(sbindir)/\" $(NCURSES_CFLAGS)
+
+ if !WANT_STATIC
+ pkglib_LTLIBRARIES = libqingy.la
+@@ -35,7 +35,7 @@
+ EXTRA_libqingy_la_SOURCES = \
+ crypto_openssl.c crypto_libgcrypt.c crypto.h
+
+-libqingy_la_LIBADD = @PASSWDLIB@ @CRYPTOLIB@ @NCURSESLIB@ @XLIBS@
++libqingy_la_LIBADD = @PASSWDLIB@ @CRYPTOLIB@ @XLIBS@ $(NCURSES_LIBS)
+ libqingy_la_LDFLAGS = -release @VERSION@
+
+ libqingy_static_la_SOURCES = $(libqingy_la_SOURCES)
diff --git a/sys-apps/qingy/qingy-1.0.0.ebuild b/sys-apps/qingy/qingy-1.0.0.ebuild
index dccb802e2c78..31c6fc5e9650 100644
--- a/sys-apps/qingy/qingy-1.0.0.ebuild
+++ b/sys-apps/qingy/qingy-1.0.0.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-1.0.0.ebuild,v 1.5 2012/05/04 09:17:27 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-1.0.0.ebuild,v 1.6 2013/03/05 10:10:31 ssuominen Exp $
-EAPI="2"
+EAPI=5
+inherit autotools elisp-common eutils pam
-inherit elisp-common eutils pam
-
-GENTOO_THEME_VERSION="2.1"
+GENTOO_THEME_VERSION=2.1
DESCRIPTION="a DirectFB getty replacement"
HOMEPAGE="http://qingy.sourceforge.net/"
@@ -18,26 +17,31 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="crypt directfb emacs gpm opensslcrypt pam static X"
-RDEPEND=">=sys-libs/ncurses-5.4-r6
- opensslcrypt? ( >=dev-libs/openssl-0.9.7e )
- crypt? ( >=dev-libs/libgcrypt-1.2.1 )
- directfb? ( >=dev-libs/DirectFB-1.4.2[fbcon,jpeg,png,truetype] )
- emacs? ( virtual/emacs )
- pam? ( >=sys-libs/pam-0.75-r11 )
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver
- x11-proto/scrnsaverproto )"
-
+RDEPEND=">=sys-libs/ncurses-5.7-r7:=
+ opensslcrypt? ( dev-libs/openssl:0= )
+ crypt? ( >=dev-libs/libgcrypt-1.2.1:= )
+ directfb? ( >=dev-libs/DirectFB-1.4.2[fbcon,jpeg,png,truetype] )
+ emacs? ( virtual/emacs )
+ pam? ( >=sys-libs/pam-0.75-r11 )
+ X? (
+ x11-libs/libX11:=
+ x11-libs/libXScrnSaver:=
+ x11-proto/scrnsaverproto
+ )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-apps/sed-4.1.4-r1"
+ >=sys-apps/sed-4.1.4-r1
+ virtual/pkgconfig"
RDEPEND="${RDEPEND}
pam? ( sys-auth/pambase )"
SITEFILE=50${PN}-gentoo.el
-src_configure()
-{
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
local crypto_support="--disable-crypto"
local emacs_support="--disable-emacs --without-lispdir"
@@ -48,55 +52,51 @@ src_configure()
echo
fi
- use emacs && emacs_support="--enable-emacs --with-lispdir=${SITELISP}/${PN}"
+ use emacs && emacs_support="--enable-emacs --with-lispdir=${SITELISP}/${PN}"
use opensslcrypt && crypto_support="--enable-crypto=openssl"
- use crypt && crypto_support="--enable-crypto=libgcrypt"
- econf \
- --sbindir=/sbin \
- --disable-optimizations \
- `use_enable pam` \
- `use_enable static static-build` \
- `use_enable gpm gpm-lock` \
- `use_enable X x-support` \
- `use_enable directfb DirectFB-support` \
- ${crypto_support} \
- ${emacs_support} \
- || die "Configuration failed"
+ use crypt && crypto_support="--enable-crypto=libgcrypt"
+ econf \
+ --sbindir=/sbin \
+ --disable-optimizations \
+ $(use_enable pam) \
+ $(use_enable static static-build) \
+ $(use_enable gpm gpm-lock) \
+ $(use_enable X x-support) \
+ $(use_enable directfb DirectFB-support ) \
+ ${crypto_support} \
+ ${emacs_support}
}
-src_install()
-{
+src_install() {
# Copy documentation manually as make install only installs info files
# INSTALL is left because it contains also configuration informations
dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
# Install the program
- emake DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" install
# Set the settings file umask to 600, in case somebody
# wants to make use of the autologin feature
- /bin/chmod 600 "${D}/etc/qingy/settings"
+ /bin/chmod 600 "${D}"/etc/qingy/settings
# Install Gentoo theme
dodir /usr/share/${PN}/themes/gentoo
- cp "${WORKDIR}"/gentoo/* "${D}/usr/share/${PN}/themes/gentoo" \
- || die "Gentoo theme installation failed"
+ cp "${WORKDIR}"/gentoo/* "${D}"/usr/share/${PN}/themes/gentoo || die
# Alter config file so that it uses our theme
- sed -i 's/theme = "default"/theme = "gentoo"/' "${D}/etc/${PN}/settings"
+ sed -i 's/theme = "default"/theme = "gentoo"/' "${D}"/etc/${PN}/settings
# Install log rotation policy
insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}-logrotate" ${PN} || die "Log rotation policy installation failed"
+ newins "${FILESDIR}"/${PN}-logrotate ${PN}
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- rm "${D}/etc/pam.d/qingy"
+ rm "${D}"/etc/pam.d/qingy
pamd_mimic system-local-login qingy auth account password session
}
-pkg_postinst()
-{
+pkg_postinst() {
einfo "In order to use qingy you must first edit your /etc/inittab"
einfo "Check the documentation at ${HOMEPAGE}"
einfo "for instructions on how to do that."