summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-10 10:18:58 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-10 10:18:58 +0000
commitb7ba9bdacbf6dc93613d2599025fac4d2c57b3c6 (patch)
tree42d45a82d10c6692b395a8c0452b2d60c5f31b3a /sys-apps/quota/quota-3.09.ebuild
parentBumped to stable (diff)
downloadgentoo-2-b7ba9bdacbf6dc93613d2599025fac4d2c57b3c6.tar.gz
gentoo-2-b7ba9bdacbf6dc93613d2599025fac4d2c57b3c6.tar.bz2
gentoo-2-b7ba9bdacbf6dc93613d2599025fac4d2c57b3c6.zip
quotactl.2 manpage collision with sys-apps/manpages
Diffstat (limited to 'sys-apps/quota/quota-3.09.ebuild')
-rw-r--r--sys-apps/quota/quota-3.09.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sys-apps/quota/quota-3.09.ebuild b/sys-apps/quota/quota-3.09.ebuild
index cd8b70ac9b57..59d6c761ab5f 100644
--- a/sys-apps/quota/quota-3.09.ebuild
+++ b/sys-apps/quota/quota-3.09.ebuild
@@ -1,30 +1,36 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.09.ebuild,v 1.2 2003/11/23 23:49:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quota/quota-3.09.ebuild,v 1.3 2003/12/10 10:18:57 seemant Exp $
IUSE="nls tcpd"
S=${WORKDIR}/quota-tools
DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
RESTRICT="nomirror"
-HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
DEPEND="virtual/glibc
tcpd? ( sys-apps/tcp-wrappers )"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
+
sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
- econf || die
- emake || die
}
src_install() {
- dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,2,3,8}}
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
make ROOTDIR=${D} install || die
# install -m 644 warnquota.conf ${D}/etc
insinto /etc