summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:40:19 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:40:19 +0000
commit01897c0b3f0f59f04fc94ca671042eea1d650e5b (patch)
tree2d627676a9affc7337f595567f15fead83b1219e /sys-apps/rigo-daemon/rigo-daemon-136.ebuild
parentFix init scripts #432548 thx to zunkree (diff)
downloadgentoo-2-01897c0b3f0f59f04fc94ca671042eea1d650e5b.tar.gz
gentoo-2-01897c0b3f0f59f04fc94ca671042eea1d650e5b.tar.bz2
gentoo-2-01897c0b3f0f59f04fc94ca671042eea1d650e5b.zip
version bump
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/rigo-daemon/rigo-daemon-136.ebuild')
-rw-r--r--sys-apps/rigo-daemon/rigo-daemon-136.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/rigo-daemon/rigo-daemon-136.ebuild b/sys-apps/rigo-daemon/rigo-daemon-136.ebuild
new file mode 100644
index 000000000000..e3cc00f52d6b
--- /dev/null
+++ b/sys-apps/rigo-daemon/rigo-daemon-136.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rigo-daemon/rigo-daemon-136.ebuild,v 1.1 2012/08/24 14:40:19 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+MY_PN="RigoDaemon"
+DESCRIPTION="Entropy Client DBus Services, aka RigoDaemon"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}/rigo/${MY_PN}"
+
+DEPEND=""
+RDEPEND="dev-python/dbus-python
+ dev-python/pygobject:3
+ ~sys-apps/entropy-${PV}
+ sys-auth/polkit[introspection]
+ sys-devel/gettext"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_preinst() {
+ # ask RigoDaemon to shutdown, if running
+ # TODO: this will be removed in future
+ local shutdown_exec=${EROOT}/usr/lib/rigo/${MY_PN}/shutdown.py
+ [[ -x "${shutdown_exec}" ]] && "${shutdown_exec}"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/rigo/${MY_PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/rigo/${MY_PN}"
+}