summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-11-04 04:58:35 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-11-04 04:58:35 +0000
commitf1697d154e21a2d22a64fa971c9827ff398e8eb8 (patch)
tree347f8e9e2ef36fd374343f9510989c45322fbc94 /sys-apps/s6
parentTrim empty ccache dirs automatically #517242 by Arfrever Frehtes Taifersar Ar... (diff)
downloadgentoo-2-f1697d154e21a2d22a64fa971c9827ff398e8eb8.tar.gz
gentoo-2-f1697d154e21a2d22a64fa971c9827ff398e8eb8.tar.bz2
gentoo-2-f1697d154e21a2d22a64fa971c9827ff398e8eb8.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/ChangeLog9
-rw-r--r--sys-apps/s6/s6-1.1.3.2.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/sys-apps/s6/ChangeLog b/sys-apps/s6/ChangeLog
index 0d5a3c56845e..1b375e8f0c8d 100644
--- a/sys-apps/s6/ChangeLog
+++ b/sys-apps/s6/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/s6
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/s6/ChangeLog,v 1.1 2013/10/02 23:09:29 williamh Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/s6/ChangeLog,v 1.2 2014/11/04 04:58:35 williamh Exp $
+
+*s6-1.1.3.2 (04 Nov 2014)
+
+ 04 Nov 2014; William Hubbs <williamh@gentoo.org> +s6-1.1.3.2.ebuild:
+ version bump
*s6-1.1.0 (02 Oct 2013)
diff --git a/sys-apps/s6/s6-1.1.3.2.ebuild b/sys-apps/s6/s6-1.1.3.2.ebuild
new file mode 100644
index 000000000000..7b030740432a
--- /dev/null
+++ b/sys-apps/s6/s6-1.1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/s6/s6-1.1.3.2.ebuild,v 1.1 2014/11/04 04:58:35 williamh Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="http://www.skarnet.org/software/s6/"
+SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/execline-1.3.1.1
+ >=dev-libs/skalibs-1.6.0.0"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+S=${WORKDIR}/admin/${P}
+
+src_configure()
+{
+ echo $(tc-getCC) ${CFLAGS} > conf-compile/conf-cc
+ echo $(tc-getCC) ${LDFLAGS} > conf-compile/conf-dynld
+ echo /usr/$(get_libdir)/s6 > conf-compile/conf-install-library
+ echo /$(get_libdir) > conf-compile/conf-install-library.so
+ echo $(tc-getCC) ${LDFLAGS} > conf-compile/conf-ld
+ echo > conf-compile/conf-stripbins
+ echo > conf-compile/conf-striplibs
+ rm conf-compile/flag-slashpackage
+ echo /usr/lib/skalibs/sysdeps > conf-compile/import
+ echo /usr/include/skalibs > conf-compile/path-include
+ echo /usr/include >> conf-compile/path-include
+ echo /usr/$(get_libdir)/skalibs > conf-compile/path-library
+ echo /usr/$(get_libdir) >> conf-compile/path-library
+ echo /$(get_libdir)/skalibs > conf-compile/path-library.so
+ echo /$(get_libdir) >> conf-compile/path-library.so
+}
+
+src_compile()
+{
+ emake -j1
+}
+
+src_install()
+{
+ into /
+ dobin command/*
+
+ dodoc -r examples
+ dohtml -r doc/*
+}