summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Stubbs <jstubbs@gentoo.org>2005-04-24 03:34:21 +0000
committerJason Stubbs <jstubbs@gentoo.org>2005-04-24 03:34:21 +0000
commita8acc481334cff7c6d0553a848435f045e749c54 (patch)
tree7fb5bdf46d5fac9702a9c1ed927e5b1853b2f9b5 /sys-apps/sandbox
parentStable on ppc. (diff)
downloadgentoo-2-a8acc481334cff7c6d0553a848435f045e749c54.tar.gz
gentoo-2-a8acc481334cff7c6d0553a848435f045e749c54.tar.bz2
gentoo-2-a8acc481334cff7c6d0553a848435f045e749c54.zip
Added check_multilib function
(Portage version: 1.524.2.59-cvs)
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest14
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.1-r11
-rw-r--r--sys-apps/sandbox/sandbox-1.2.1-r1.ebuild88
4 files changed, 98 insertions, 12 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index c0179d61600c..19663e92967a 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.3 2005/04/23 21:13:25 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.4 2005/04/24 03:34:21 jstubbs Exp $
+
+*sandbox-1.2.1 (24 Apr 2005)
+
+ 24 Apr 2005; Jason Stubbs <jstubbs@gentoo.org> +sandbox-1.2.1-r1.ebuild:
+ Added missing check_multilib function.
*sandbox-1.2.1 (23 Apr 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index ef3344fbd4ba..f4dfd180ea7e 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9fd5eb46e8da4d0e78fa40bc39f3b602 ChangeLog 523
+MD5 e7aed62bed76e81f806eeb52b296af86 ChangeLog 670
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 fa4e917c828593f1c202fe11f019e2d3 sandbox-1.2.ebuild 1711
MD5 47438c0ad7e347064cdaf223d6a5f042 sandbox-1.2.1.ebuild 1747
+MD5 21f0389b2ac2dab7c2d90fa24e9a6235 sandbox-1.2.1-r1.ebuild 2127
MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCart01ZcsMnZjRyIRAmNiAJ4kJu3RSxqB1zvpakFrlUOmBUih+wCgsdE9
-6ROu5LkOxLk14PvmrEWEaDM=
-=TJvK
------END PGP SIGNATURE-----
+MD5 9b60e9e6d1e45533a0e719fdf023ec07 files/digest-sandbox-1.2.1-r1 66
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.1-r1 b/sys-apps/sandbox/files/digest-sandbox-1.2.1-r1
new file mode 100644
index 000000000000..6cdf0c26f8f5
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.1-r1
@@ -0,0 +1 @@
+MD5 233586e779d83a260cb747c982acdaa2 sandbox-1.2.1.tar.bz2 220410
diff --git a/sys-apps/sandbox/sandbox-1.2.1-r1.ebuild b/sys-apps/sandbox/sandbox-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..07539fcc42f8
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.1-r1.ebuild,v 1.1 2005/04/24 03:34:21 jstubbs Exp $
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+IUSE=""
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+DEPEND=""
+LICENSE="GPL-2"
+SLOT='0'
+
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ]; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ fi
+}
+
+src_unpack() {
+ if has_multilib_profile; then
+ for TA in $(get_install_abis); do
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ cd ..
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ fi
+}
+
+src_compile() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64; then
+ check_multilib
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH=${MULTILIB}"
+ fi
+ cd ${S}
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einstall || die "einstall failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ cd ${S}
+ einstall || die "einstalled failed"
+ fi
+}