summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-24 12:00:38 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-24 12:00:38 +0000
commitac3f512a5af25f70bf8315183ae75b32211155fe (patch)
tree1e7376f9b55d24ec8008013d293b8a39a4023922 /sys-apps/shadow
parentalpha stable (diff)
downloadgentoo-2-ac3f512a5af25f70bf8315183ae75b32211155fe.tar.gz
gentoo-2-ac3f512a5af25f70bf8315183ae75b32211155fe.tar.bz2
gentoo-2-ac3f512a5af25f70bf8315183ae75b32211155fe.zip
Version bump.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-apps/shadow')
-rw-r--r--sys-apps/shadow/ChangeLog8
-rw-r--r--sys-apps/shadow/files/shadow-4.1.0-fix-useradd-usergroups.patch91
-rw-r--r--sys-apps/shadow/shadow-4.1.0.ebuild160
3 files changed, 258 insertions, 1 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index 9b81ecc39575..c81f186e713e 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/shadow
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.183 2008/02/24 11:02:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.184 2008/02/24 12:00:37 vapier Exp $
+
+*shadow-4.1.0 (24 Feb 2008)
+
+ 24 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/shadow-4.1.0-fix-useradd-usergroups.patch, +shadow-4.1.0.ebuild:
+ Version bump.
24 Feb 2008; Mike Frysinger <vapier@gentoo.org>
files/shadow-4.0.17-login.defs.patch, shadow-4.0.18.1-r1.ebuild,
diff --git a/sys-apps/shadow/files/shadow-4.1.0-fix-useradd-usergroups.patch b/sys-apps/shadow/files/shadow-4.1.0-fix-useradd-usergroups.patch
new file mode 100644
index 000000000000..8595ec39a91f
--- /dev/null
+++ b/sys-apps/shadow/files/shadow-4.1.0-fix-useradd-usergroups.patch
@@ -0,0 +1,91 @@
+http://bugs.gentoo.org/128715
+
+exact implementation details are still in discussion upstream, but this fixes
+the behavior to not suck like current code
+
+--- src/useradd.c
++++ src/useradd.c
+@@ -254,6 +254,12 @@
+ char *cp, *ep;
+
+ /*
++ * Pull relevant settings from login.defs first.
++ */
++ if (getdef_bool ("USERGROUPS_ENAB"))
++ nflg = -1;
++
++ /*
+ * Open the defaults file for reading.
+ */
+
+@@ -632,6 +638,8 @@
+ " -K, --key KEY=VALUE overrides /etc/login.defs defaults\n"
+ " -m, --create-home create home directory for the new user\n"
+ " account\n"
++ " -n, --user-group create a new group with the same name as the\n"
++ " new user\n"
+ " -o, --non-unique allow create user with duplicate\n"
+ " (non-unique) UID\n"
+ " -p, --password PASSWORD use encrypted password for the new user\n"
+@@ -1001,6 +1009,7 @@
+ {"skel", required_argument, NULL, 'k'},
+ {"key", required_argument, NULL, 'K'},
+ {"create-home", no_argument, NULL, 'm'},
++ {"user-group", no_argument, NULL, 'n'},
+ {"non-unique", no_argument, NULL, 'o'},
+ {"password", required_argument, NULL, 'p'},
+ {"shell", required_argument, NULL, 's'},
+@@ -1008,7 +1017,7 @@
+ {NULL, 0, NULL, '\0'}
+ };
+ while ((c =
+- getopt_long (argc, argv, "b:c:d:De:f:g:G:k:K:mMop:s:u:",
++ getopt_long (argc, argv, "b:c:d:De:f:g:G:k:K:mMnop:s:u:",
+ long_options, NULL)) != -1) {
+ switch (c) {
+ case 'b':
+@@ -1145,6 +1154,9 @@
+ case 'm':
+ mflg++;
+ break;
++ case 'n':
++ nflg = 1;
++ break;
+ case 'o':
+ oflg++;
+ break;
+@@ -1192,6 +1204,16 @@
+ usage ();
+
+ /*
++ * Using --gid and --user-group doesn't make sense.
++ */
++ if (nflg == -1 && gflg)
++ nflg = 0;
++ if (nflg && gflg) {
++ fprintf (stderr, _("%s: options -g and -n conflict\n"), Prog);
++ exit (E_BAD_ARG);
++ }
++
++ /*
+ * Either -D or username is required. Defaults can be set with -D
+ * for the -b, -e, -f, -g, -s options only.
+ */
+@@ -1728,7 +1750,7 @@
+ * to that group, use useradd -g username username.
+ * --bero
+ */
+- if (!gflg) {
++ if (nflg) {
+ if (getgrnam (user_name)) { /* local, no need for xgetgrnam */
+ fprintf (stderr,
+ _
+@@ -1762,7 +1784,7 @@
+
+ /* do we have to add a group for that user? This is why we need to
+ * open the group files in the open_files() function --gafton */
+- if (!(nflg || gflg)) {
++ if (nflg) {
+ find_new_gid ();
+ grp_add ();
+ }
diff --git a/sys-apps/shadow/shadow-4.1.0.ebuild b/sys-apps/shadow/shadow-4.1.0.ebuild
new file mode 100644
index 000000000000..278c90557142
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.1.0.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.1.0.ebuild,v 1.1 2008/02/24 12:00:37 vapier Exp $
+
+inherit eutils libtool toolchain-funcs autotools pam multilib
+
+DESCRIPTION="Utilities to deal with user accounts"
+HOMEPAGE="http://shadow.pld.org.pl/ http://packages.qa.debian.org/s/shadow.html"
+SRC_URI="mirror://debian/pool/main/s/shadow/shadow_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls pam selinux skey cracklib"
+
+RDEPEND="cracklib? ( >=sys-libs/cracklib-2.7-r3 )
+ pam? ( >=sys-libs/pam-0.99 )
+ !sys-apps/pam-login
+ !app-admin/nologin
+ skey? ( app-admin/skey )
+ selinux? ( >=sys-libs/libselinux-1.28 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # If su should not simulate a login shell, use '/bin/sh' as shell to enable
+ # running of commands as user with /bin/false as shell, closing bug #15015.
+ # *** This one could be a security hole; disable for now ***
+ #epatch "${FILESDIR}"/${P}-nologin-run-sh.patch
+
+ # tweak the default login.defs
+ epatch "${FILESDIR}"/${PN}-4.0.17-login.defs.patch
+ sed -i "s:@LIBDIR@:$(get_libdir):" etc/login.defs || die
+
+ # Make user/group names more flexible #3485 / #22920
+ epatch "${FILESDIR}"/${PN}-4.0.13-dots-in-usernames.patch
+ epatch "${FILESDIR}"/${PN}-4.0.13-long-groupnames.patch
+ epatch "${FILESDIR}"/${PN}-4.1.0-fix-useradd-usergroups.patch #128715
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ tc-is-cross-compiler && export ac_cv_func_setpgrp_void=yes
+ econf \
+ --disable-desrpc \
+ --with-libcrypt \
+ --enable-shared=no \
+ --enable-static=yes \
+ $(use_with cracklib libcrack) \
+ $(use_with pam libpam) \
+ $(use_with skey) \
+ $(use_with selinux) \
+ $(use_enable nls) \
+ || die "bad configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" suidperms=4711 install || die "install problem"
+ dosym useradd /usr/sbin/adduser
+
+ # Remove libshadow and libmisc; see bug 37725 and the following
+ # comment from shadow's README.linux:
+ # Currently, libshadow.a is for internal use only, so if you see
+ # -lshadow in a Makefile of some other package, it is safe to
+ # remove it.
+ rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins "${FILESDIR}"/securetty
+ if ! use pam ; then
+ insopts -m0600
+ doins etc/login.access etc/limits
+ fi
+ # Output arch-specific cruft
+ case $(tc-arch) in
+ ppc*) echo "hvc0" >> "${D}"/etc/securetty
+ echo "hvsi0" >> "${D}"/etc/securetty
+ echo "ttyPSC0" >> "${D}"/etc/securetty;;
+ hppa) echo "ttyB0" >> "${D}"/etc/securetty;;
+ arm) echo "ttyFB0" >> "${D}"/etc/securetty;;
+ sh) echo "ttySC0" >> "${D}"/etc/securetty
+ echo "ttySC1" >> "${D}"/etc/securetty;;
+ esac
+
+ # needed for 'adduser -D'
+ insinto /etc/default
+ insopts -m0600
+ doins "${FILESDIR}"/default/useradd
+
+ # move passwd to / to help recover broke systems #64441
+ mv "${D}"/usr/bin/passwd "${D}"/bin/
+ dosym /bin/passwd /usr/bin/passwd
+
+ cd "${S}"
+ insinto /etc
+ insopts -m0644
+ newins etc/login.defs login.defs
+
+ if use pam ; then
+ dopamd "${FILESDIR}/pam.d-include/"{su,passwd,shadow}
+
+ newpamd "${FILESDIR}/login.pamd.2" login
+
+ for x in chage chsh chfn chpasswd newusers \
+ user{add,del,mod} group{add,del,mod} ; do
+ newpamd "${FILESDIR}"/pam.d-include/shadow ${x}
+ done
+
+ # comment out login.defs options that pam hates
+ gawk -f "${FILESDIR}"/login_defs.awk \
+ lib/getdef.c etc/login.defs \
+ > "${D}"/etc/login.defs
+
+ # remove manpages that pam will install for us
+ # and/or don't apply when using pam
+ find "${D}"/usr/share/man \
+ '(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
+ -exec rm {} \;
+ fi
+
+ # Remove manpages that are handled by other packages
+ find "${D}"/usr/share/man \
+ '(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
+ -exec rm {} \;
+
+ cd "${S}"
+ dodoc ChangeLog NEWS TODO
+ newdoc README README.download
+ cd doc
+ dodoc HOWTO README* WISHLIST *.txt
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}"/etc/pam.d/system-auth.new \
+ "${ROOT}/etc/login.defs.new"
+
+ use pam && pam_epam_expand "${D}"/etc/pam.d/login
+}
+
+pkg_postinst() {
+ # Enable shadow groups (we need ROOT=/ here, as grpconv only
+ # operate on / ...).
+ if [[ ${ROOT} == / && ! -f /etc/gshadow ]] ; then
+ if grpck -r &>/dev/null; then
+ grpconv
+ else
+ ewarn "Running 'grpck' returned errors. Please run it by hand, and then"
+ ewarn "run 'grpconv' afterwards!"
+ fi
+ fi
+}