summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-06-30 19:45:29 +0000
committerPeter Johanson <latexer@gentoo.org>2003-06-30 19:45:29 +0000
commit97d7a5b60a52d0a3265606914cc6c4fef3aab0ea (patch)
treef94e1e5bf74f3faa33c9572b2700c06007958cfa /sys-apps/tpb
parentFixed xosd support. bug#23617 (diff)
downloadgentoo-2-97d7a5b60a52d0a3265606914cc6c4fef3aab0ea.tar.gz
gentoo-2-97d7a5b60a52d0a3265606914cc6c4fef3aab0ea.tar.bz2
gentoo-2-97d7a5b60a52d0a3265606914cc6c4fef3aab0ea.zip
Fixed xosd support. bug#23617
Diffstat (limited to 'sys-apps/tpb')
-rw-r--r--sys-apps/tpb/ChangeLog6
-rw-r--r--sys-apps/tpb/Manifest4
-rw-r--r--sys-apps/tpb/files/tpb-0.5.1-configure-fix.patch16
-rw-r--r--sys-apps/tpb/tpb-0.5.1.ebuild8
4 files changed, 30 insertions, 4 deletions
diff --git a/sys-apps/tpb/ChangeLog b/sys-apps/tpb/ChangeLog
index cc8426b62400..30f38e7b5dde 100644
--- a/sys-apps/tpb/ChangeLog
+++ b/sys-apps/tpb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/tpb
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpb/ChangeLog,v 1.2 2003/04/15 14:04:35 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpb/ChangeLog,v 1.3 2003/06/30 19:45:24 latexer Exp $
+
+ 30 Jun 2003; Peter Johanson <latexer@gentoo.org> tpb-0.5.1.ebuild,
+ files/tpb-0.5.1-configure-fix.patch:
+ Added patch to correct enable/disable xosd support
*tpb-0.5.1 (16 Apr 2003)
diff --git a/sys-apps/tpb/Manifest b/sys-apps/tpb/Manifest
index da7d6d765151..5e65f2eb2986 100644
--- a/sys-apps/tpb/Manifest
+++ b/sys-apps/tpb/Manifest
@@ -1,6 +1,6 @@
MD5 befe406735bdf4cbc862006f475e51ac tpb-0.4.2.ebuild 663
-MD5 adacad7a99110aff3231d7361724a181 tpb-0.5.1.ebuild 797
-MD5 4e1e3332ef401ad8217a4a8c5bd306f1 ChangeLog 423
+MD5 5de69a28208df92a4f70fcc2320e1283 tpb-0.5.1.ebuild 796
+MD5 b4e9c7821973255bb163c1f0f114afa9 ChangeLog 585
MD5 5cba07339a0908c048f81d7b21dc9d36 files/tpb-0.5.1-configure-fix.patch 478
MD5 69f14f1aff93cd330a33f4dff7faeaa5 files/digest-tpb-0.4.2 60
MD5 e17af97421dc0cf66db7df20b072a8fc files/digest-tpb-0.5.1 61
diff --git a/sys-apps/tpb/files/tpb-0.5.1-configure-fix.patch b/sys-apps/tpb/files/tpb-0.5.1-configure-fix.patch
new file mode 100644
index 000000000000..7dc4683d158b
--- /dev/null
+++ b/sys-apps/tpb/files/tpb-0.5.1-configure-fix.patch
@@ -0,0 +1,16 @@
+diff -aur tpb-0.5.1/configure tpb-0.5.1-patched/configure
+--- tpb-0.5.1/configure 2003-04-10 04:06:26.000000000 -0400
++++ tpb-0.5.1-patched/configure 2003-06-30 12:06:41.000000000 -0400
+@@ -790,10 +790,10 @@
+
+ # additional options
+ # Check whether --enable-xosd or --disable-xosd was given.
+-if test "${enable_xosd+set}" = set; then
+- enableval="$enable_xosd"
++if test "x${enable_xosd}" = xno; then
+ enable_xosd=no
+ else
++ enableval="$enable_xosd"
+ enable_xosd=yes
+ fi
+
diff --git a/sys-apps/tpb/tpb-0.5.1.ebuild b/sys-apps/tpb/tpb-0.5.1.ebuild
index 6ce749d7b11d..1aab4cc664e4 100644
--- a/sys-apps/tpb/tpb-0.5.1.ebuild
+++ b/sys-apps/tpb/tpb-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpb/tpb-0.5.1.ebuild,v 1.2 2003/06/21 21:19:41 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpb/tpb-0.5.1.ebuild,v 1.3 2003/06/30 19:45:24 latexer Exp $
DESCRIPTION="Thinkpad button utility"
HOMEPAGE="http://savannah.nongnu.org/projects/tpb/"
@@ -13,6 +13,12 @@ IUSE="X nls"
DEPEND="X? ( x11-libs/xosd )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-configure-fix.patch
+}
+
src_compile() {
econf `use_enable X xosd` `use_enable nls`