summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-13 20:39:15 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-13 20:39:15 +0000
commit319d60116c03b3629c09a801a3d2e2c7c5708d3a (patch)
tree02234789da2e87898603d3a316422ec9f52f802d /sys-apps/uam
parentVersion bump (diff)
downloadgentoo-2-319d60116c03b3629c09a801a3d2e2c7c5708d3a.tar.gz
gentoo-2-319d60116c03b3629c09a801a3d2e2c7c5708d3a.tar.bz2
gentoo-2-319d60116c03b3629c09a801a3d2e2c7c5708d3a.zip
Version bump. The new version uses autotools as the buildsystem.
(Portage version: 2.2.0_alpha15_p1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/uam')
-rw-r--r--sys-apps/uam/ChangeLog9
-rw-r--r--sys-apps/uam/uam-0.0.7.1.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/sys-apps/uam/ChangeLog b/sys-apps/uam/ChangeLog
index 07b209c03a1b..13fa1a9c651d 100644
--- a/sys-apps/uam/ChangeLog
+++ b/sys-apps/uam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/uam
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/ChangeLog,v 1.7 2010/12/20 14:37:39 mgorny Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/ChangeLog,v 1.8 2011/01/13 20:39:15 mgorny Exp $
+
+*uam-0.0.7.1 (13 Jan 2011)
+
+ 13 Jan 2011; Michał Górny <mgorny@gentoo.org> +uam-0.0.7.1.ebuild:
+ Version bump. The new version uses autotools as the buildsystem.
20 Dec 2010; Michał Górny <mgorny@gentoo.org> uam-0.0.7.ebuild:
Change the SRC_URIs to use cloud.github.com directly. This avoids issues with
diff --git a/sys-apps/uam/uam-0.0.7.1.ebuild b/sys-apps/uam/uam-0.0.7.1.ebuild
new file mode 100644
index 000000000000..6b8bae0510af
--- /dev/null
+++ b/sys-apps/uam/uam-0.0.7.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/uam-0.0.7.1.ebuild,v 1.1 2011/01/13 20:39:15 mgorny Exp $
+
+EAPI=3
+inherit autotools-utils eutils multilib
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://github.com/mgorny/uam/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/udev"
+DEPEND="${RDEPEND}"
+
+DOCS=( NEWS README )
+
+src_configure() {
+ myeconfargs=(
+ --libdir=/$(get_libdir)
+ )
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "Another feature uam is not capable of is mounting removable media"
+ elog "in fixed drives, like CDs and floppies. You might, however, be able"
+ elog "to mount them as an unprivileged user using appropriate fstab entries"
+ elog "or [sys-apps/pmount]."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool from the Sunrise"
+ elog "overlay [1] (or bug #318961 [2])."
+ elog
+ elog "[1] http://overlays.gentoo.org/proj/sunrise"
+ elog "[2] http://bugs.gentoo.org/show_bug.cgi?id=318961"
+
+ if [[ -e "${EROOT}"/dev/.udev ]]; then
+ ebegin "Calling udev to reload its rules"
+ udevadm control --reload-rules
+ eend $?
+ fi
+}